Egy kis bevezetõ.... (avagy, ahogy Krow is írta :-)
A weblapok az elmúlt pár esztendõben nagy változásokon mentek keresztül. A kezdeti egyszerü lapokat felváltották a multimédiás képességekkel felruházott weblapok. KüIönbözõ animációk helyezhetõk el az oldalon stb. Ugyanezen az evolúciós idõszakon természetesen átestek a weblapszerkesztõ programok is. Mint jól tudjuk, egy HTML dokumentumot elkészíthettünk akár a jegyzettömb segítségével is, de ember a talpán, aki egy bonyolultabb oldalt ilyen módon létrehoz. Az ily módon végzett munkához ismerni kell az összes HTML vezérlõelemet és az oldal felépítése is sokkal több idõt fog igénybe venni, mintha valamelyik szoftvert használnánk. Az idõk folyamán a weblapszerkesztõ szoftverek rengeteget fejlõdtek. Némi jóindulattal (szerintem)elmondható, hogy jelenleg ennek a fejlõdésnek a csúcsán áll a Macromedia Dreamweaver weblapszerkesztõ is. A program ismeri az újabb HTML szabványokat is, így módunk van a modern vezérlõelemek használatára is. Könnyedén elhelyezhettünk a dokumentumban ActiveX objektumokat, vagy akár java appleteket is. A Dreamweaver támogatja az ImageMap funkciót, tehát egy kép bizonyos részeihez könnyedén rendelhettünk hozzá egy hiperhivatkozást. Aki próbált már bonyolultabb menüket készíteni, annak nem kell ecsetelni ennek a funkciónak a jelentõségét. A frame-ek kezelése is gyerekjáték a Dreamweaver-rel. 

 

Újdonságok:
A Dreamweaver támogatja a 4.0-s HTML szabványt is. Ennek megfelelõen a layerek használatával többrétegû oldalt készíthetünk, sõt akár réteganimációkat is. A layerek használata a képek és a szövegek elhelyezését is nagymértékben megkönnyíti, ugyanis a layer az oldalon bárhova (pl. akár egy tized milliméterrel feljebb vagy lejjebb is) elhelyezhetõk. Ez pedig roppant szimpatikus tulajdonság, hiszen más weblapszerkesztõ programok nem minden esetben teszik lehetõvé a képek pontos beállítását. A layerek egymásra is húzhatóak, le is takarhatják egymást. Újdonságot jelent az is, hogy leellenõrizhetjük, hogy az általunk használt HTML elemeket ismerik-e a korábbi 2.0/3.0-s böngészõprogramok. Megtehetjük, hogy oldalainkat átkonvertáljuk 3.0-s böngészõkkel kompatibilis formátumba, de ekkor elvszítjuk a layerek okozta elõnyöket. A Dreamweaver segítségével még az oldalban elhelyezett hiperhivatkozások helyes mûködése is ellenõrizhetõ. Más WYSIWYC* szerkesztõknél gyakran elõfordult, hogy az oldalban elhelyezett scripteket, mint például egy számlálóscriptre történõ hivatkozás, egész egyszerûen nem voltak hajlandóak elmenteni. Ez azzal járt, hogy a script beszúrása után már csak az oldal forrását volt célszerû piszkálni, sok bosszúságot okozva a készítõnek. A Dreamweaver ebben is nagyon barátságos, egyáltalán nem nyúl az ilyen típusú hivatkozásokhoz. Nagy segítséget nyújt a program abban is hogy az egyes objektumokhoz viselkedési módokat társítsunk. Nincs szükség csak pár egérkattintásra, és máris telerakhatjuk az oldalt dinamikusan változó gombokkal. Az eseménykezelõ metódusok a böngészõk különbözõ verziói szerint vannak csoportosítva, tehát nyugodtan tervezhetünk csak 3-as, vagy csak 4-es verzióra. Munka közben egy ablakban megtekinthetõ az oldal forrása is. A forráson végzett változtatások természetesen azonnal érvényesülnek a dokumentumban is. Ha ez valakit esetleg nem elégít ki, az természetesen használhat bármilyen más alkalmazást a HTML-forrás szerkesztésére. Összességében tehát egy könnyen kezelhetõ, sokoldalú HTML szerkesztõvel van dolgunk, amely a weblapok felépítését, kezelését, karbantartását nagyban megkönnyíti.  

*WYSIWYG: What You See Is What You Get: Azt kapod, amit látsz 

 

Forró Billentyûk
Bill Gates is Ezt Veri ...
Szóval egy két fontosabb billentyû kombináció az egyszerübb kezeléshez:
( Természetesen, ha végigmész a menükön meglátod ezeket :-)

- CTRL+N >> Új lap készítése
- CTRL+O >> Megnyitás egy doksinak
- CTRL+S >> Mentés
- CTRL+SHIFT+S >> Mentás mindent (Ez a Frame kezelésnél kell, amikor nem kell minden Frame-et külön lementeni)
- F12 ill. SHIFT F12 >> Ha van böngészöd a gépen akkor egy gombnyomásra meg tudod nézni azt amit eddig csináltál. Sõt Két fajta böngészõben is meg tudod csinálni ugyan ezt. (IE<--> Netcápa Rulez)

No és a lényeg: 
- ENTER >> "Nagy" kihagyás a Sorok között
- SHIFT+ENTER >> "Kis" kihagyás a Sorok között

 

A Dreamweaver Elõnyei (MI szerintünk)
Ezt órákig lehetne sorolni, ugyanis rengeteg többlet funkciója van, Így például:
- Álandó Properties ablak- Itt mindig látható az éppen aktuális Objaktum tulajdonsága és annak megváltoztatásainak a lehetõsége + FRame tulajdonságok + Táblázat tulajdonságok ....
- Forró Gombok az Objects panelen - Itt rengeteg elõre legyártott Objektumot lehet beszúrni rettentõen egyszerûen pl: Kép, Táblázat, Visszintes Vonal, Layer, ActiveX, Java Script, ImageMAP (!!!), Flash, Shockwave, Gombok, Anchorok, Comment... És még sok-sok más
- Beépített Image Map Készítõ varázsló- No Commnet. CooL
- Rettentõen egyszerû Táblázatkezelés- Ez így van, majd még kitérek rá
- Kettõs megjelenítés- HTML Forrás (pl: itt szúrod be a Java Scriptet) + Grafikus megjelenítés (pl: Itt gépelsz)
- Site Térkép - Az általad készített oldalakról készít egy Fa struktúrát Link kapcsolódás szerint, ezzel könnyebb lesz az áttekinthetõség
- Beépített Java Script generátor - Rengeteg Java Script eleve beépítve.. Késõbb.. Nyugi...
- Rengeteg objektum beilleszthetõségi lehetõség - Pl Java Script, Applet, ActiveX, Plugin, Flash, Schockwave
- ActiveX kezelése- YESS - Windows 98 !!!*.htt :-)))))
- Kompatibilitási tesztelés lehetõsége akár melyik Böngészõ tipusra és verzióra (4.0-ig) - No Comment - Super !
- Böngészõkben való megjelenítés - két fajta böngészõben meg tudod jeleníteni az elkészített oldaladat egy gombnyomásra. Gondoltak a Netscape és az IE készítõire ...
- Forrás Tesztelés- Szó Szerint. Megkérdezi, milyen tipusura, milyen verzióra... És Tesztel .. Kiirja a hibákat (Netscape 2.0, 3.0, 4.0; IE 2.0 3.0, 4.0)
- Link Tesztelés- Tuti biztos, ha elavult linkeket keresel az oldaladon. Igaz én még nem használatm :-(
- CTRL+C, CTRL+V még a forrásban ill. a grafikus megjelenítésnél is - Ez a legjobb 
- Az Objektumok könnyû kezelése, pl: minden Objektum tipust (Java, JavaScript, ActiveX, Falsh...) más jelképpel tudunk jelölni a Grafikus megjelenítésnél (ugyanis itt elvileg nem látszik)
- A HTML Forrás és a Grafikus felület szinkronja - Ha a Grafikus felületen kijelölök pl egy szöveg részletet, akkor az a HTML forrásba is kijelölõdik.... Hiba keresés, ezek után már Gyerekjáték
- Nagyon Egyszerû Szöveg kezelési lehetõség- Editálni, színezni, Méretet váltiztatni... Mint a Word-ben
- Nem fontos dolgokat ki tudja törölni magától a Progi (pl: Commentek, üres "tag-ok", ...) ezzel a méretet lehet csökkenteni :-)
- Elõre beépített Szín Sémák - A Sablon készítésnél tud adni néhány jó ötletet
- Táblázat automatikus formázása (ez ugyan olyan mint a Word-ben !!!) Sablonok szerint
- Egyszerû Layer kezelés - Szó Szerint
- Színkezelés - Mintavétellel történik a képernyõ bármely részérõl, akár egy kép hátterébõl is !!!

És még......... De egyszerûen képtelenség leírni minden jót, ami itt bennvan és másban nincs. 

Ja majdnem elfelejtettem:
- Te be tudod állítani, hogy hányszor hányas Oldalt akarsz csinálni ... 640x480 tól 1024x 768 ig. 
- Egy másik kis ablakban kijelzi az épp aktuális oldal méretét és annak várható letöltési idejét. Pl most ez a doksi 115k/32 sec-en áll....Eddig...Lesz Ez Még Így Se :-)
- A legegyszerübb Frame kezelés !!!! Pl: meg tudod választani, hogy melyik link melyik frame-be nyitódjon meg + ....

 

A Dreamweaver használata
Új Dokumentum készítése
Tehát elsõ lépés egy Új Honlap elkészítésében, egy kezdõ lap (Sablon) készítése.

Indítsuk el a Dreamweaver programot.Ekkor egy Fehér képernyõ jelenik meg felül menüpontokkal.
Háttér Megválasztása:

Nyomjunk jobb klikket a Fehér Lap valamely részére.Válasszuk a Page Properties Menüpontot.Itt rengeteg fontos dolgot tudunk beállítani: 

- Title >>A Lap címe, ami a böngészõn felül fog megjelenni
- Background Image >> Háttér kép kiválasztása
- Background >> Háttérszín megválasztása, ha nincs kép
- Text >> Szöveg szín megválasztása
- Links >> Linkek színének megválasztása
- Visited Links >> Már meglátogatott linkek színének megválasztása
- Active Links >> Az éppen aktív link színének megválasztása
- Document Encoding >> A Kódolása a Pagénak
- Traving Image - Ez is egy háttér szerû kép beillesztése. Én nem jötte rá hogy miért kell (???)


Ezzel kész az alapozás. Ha mindezt a Te saját igényeidnek megfelelõen változtattad meg, akkor kész egy Sablon szerû oldalad. Ekkor jön a Szöveg szerkesztése

 

Szövegek szerkesztése 
A Dreamweaver sok jó funkciója közül ez az egyik ami a legjobb a maga nemében. Teljesen olyan mint a Word szerkesztõje.
Az állandóan figyelõ Tulajdonságok panel mindig kiirja számunkra az épp aktuális objektum vagy jelen esetben a szöveg általunk megváltoztatható paramétereit.image.(képes példa)

Mint itt is látható a betütipustól kezdve akár a Wordben jól megszokott Címsorozást is el tudjuk végezni, arról nem is beszélve, hogy ahogy látszik a "Cell" feliratnál a Cellák egysítése, szétválasztása a táblázatokban nagyon egyszerû. Egy kattintás.
Tovább látunk egy %-os számot. Itt tudjuk beállítani a táblázat méreteit (Visszintes, Függõleges), akár %-ban is (A képernyõ mérteihez képest).
Továbbá a "Link" felirathoz be lehet írni azt a Linket ahova akarjuk küldeni a látogatót, ha rákkatint. (Vigyázz a http://-lel kezd el és ne a www.valami.hu-val )
A "Size" menüpont mellett be lehet állítani a színét a betütipusnak. Nagyon Cool a színmintavétalazõ része. Akár a Html objektumból is lehet szín mintát venni. Ez akkor fontos, ha egy kép mögé egy ugyan olyan színû hátteret akarsz kiválasztani. Akkor csak rámész a kép hátterére és kész is. :-)))
Itt is megtalálhatók a sorbehúzás gombok . Illetve a beszámozás automatikusan is.

 

Képek kezelése 
Mint mnden ez is pofonegyszerû a Dreamweaver-nél. Egyszerûen Insert Menüpont->>Image vagy a CTRL+ALT+I forróbillentyû. (képes példa) 

Itt is jól látható minden funkció:

A legtöbb fájlformátumot ismeri amit kell tudnia (sajnos a BMP-t át kell konvertálni valamilyen másik fájlformátumba, no de ez nem is HTML Image formátum:-) Jobb oldalon megjeleníti a képet, sõt azt is kijelzi nekünk, hogy hány mp kell a letöltéshez.Vagy akár URL hivatkozást is be lehet írni az alsó sorban :-))))

Most Jön a JAVA
Menü készítése:
A következõ leírásokban a Dreamweaverbe beépített Java Script funkciókat fogjuk kihasználni.
Hát igen a Menü. A menü a Page leglátogatottab része, így célszerû nem túl nagy méretû képeket rárakni és minden féle Java Applet alkalmazásokkal felszerelni.



Elõször is a legegyszerübb "Text verzió": (Táblázat kezeléssel) 

Hozzunk létre egy új dokumentumot. 

1. Hozzunk létre egy új dokumentumot. File/New (képes példa)
(Természetesen a színeket a te igényeidnek megfelelõen válaszd meg)(képes példa)

2. Hozzunk létre egy táblázatot. Insert/Table (képes példa) 
Itt meg tudjuk választani a cellák számát (Rows, Colomns), szlességeit a külsõ keretnek illeteve a belsõ cellák közötti hely nagyságát. Hogy lássuk mindegyikre egy példát válasszuk a következõ beállítási pontokat. Remélem most már mindez világos . (képes példa) Próbáld ki 0 beállításokkal is és érezd a különbséget :-) (Csak a Cell padding, Cell Spacing, és a Bordert változtasd meg) (képes példa) 

3. Írjunk néhány menüpontot a cellákba. (képes példa)

4. Jelöljünk ki egy szövegrészt (Bal klikk lenyomva a szöveg fölött, mint a Wordben) (képes példa)

5. Kattintsunk a Link helyre a mindig megjelenõ panelon.(képes példa) Írd be a következõt: http://w3.swi.hu/kesro . (A http:// nagyon fontos !!!) Nyomj Entert. És kész is az egyik menüpont. Ezek után a többit is ugynezzel a módszerrel meg tudod csinálni.(képes példa)

No de mennyünk egy kicsit elõre. Behavior. Java Script. Biztos láttál már te is olyan text verzióju menüpontot amire ha ráment az egér akkor a Böngészõd alsó sorában egy szöveg jelet meg. Ezt MI is meg fogjuk csinálni:-) És Te is !

6. Jelöld ki a Linkes szöveget.Nyomj egy F8-as billentyût.

7. Kattints a "+" jelre a bal felsõ sarokban. (A szöveg még midig ki van jelölve )(képes példa)

8. Jelöld ki a Display Status Message menüpontot. Írd be azt a szöveget amit ki akarsz majd jeleztetni. És kész is :-)

Ahogy látod elég sok egyéb funkció van. Próbálkozz Bátran !!!



És ha mindezt megcsináltad ezt keptad : EREDMÉNY


Most pedig nekiállhatunk a Mozgó képes menüpontok készítéséek.

Ehhez elõször is kell egy két kép. Nagyon ajánlom az Adobe Image Styler-ét . Egyszerûen csúcsszuper. 
Én ezeket a képeket fogom használni: 1 2 3 4 5 6 

Szó mi szó kezdjük elõröl. 

1. File/New (képes példa) (képes példa)

2. Illeszd be a menüpontos képeidet. Én hármat illesztetem be az Insert/Image menüpont segítségével. ezek az úgynevezett elsõk legyenek. Amik akkor jelennek meg, ha az egér nincs rajta. Majd késõbb kell beszúrni a másik "párját" (képes példa)

3. Ez után jön egy kis Java a beépített Behavior segítségével. Nyomj F8-at (ha nem lenne elöl a Behavior panel)
(Ja itt melleselg be tudod állítani, hogy a Java Script milyen böngészõvel legyen kompatibilis, de gondolom erre már rájöttél ("Events For:" menüa Behavior Panelen)) 

4.Kattints rá az elsõ képre. Kattints utánna a "+" jelre a Behavior panelen.És válaszd a Swap Image menüpontot.(képes példa)
Ekkor megjelenik egy ehhez hasonló Panel. Itt meg tudod valasztani, hogy melyik képet cserélje ki milyen képre, ha az egér a képedre érkezik. Ebbõl látszik, hogy akár egy másik képet is meg lehet változtatni, ha ezt a Behaviort választjuk.
Célszerû, ha a képet beillszted elnevezni valamilyen névre, és ekkor a kép neveként fogja megjeleníteni a kicserélendõ képet. (képes példa) (képes példa)

És kész is ... Ha valami nem világos.. Javasolom mentsd le a következõ "megvalósított" Page-et, editáld meg a Dreamweaverben, és nézd meg a képek Behavior Listáját. De szerintem 5 perc tökölõdés után ugyis rá fogsz jönni:-) Nagyon egyértelmüek. És fõleg ezek után a többi Behavior használata is. Azt hiszem ???!!??? 



És ha mindezt megcsináltad ezt keptad : EREDMÉNY
Egyéb példák:

És ha mindezt megcsináltad ezt keptad : EREDMÉNY (lehet majd...) 

És ha mindezt megcsináltad ezt keptad : EREDMÉNY (lehet majd...) 

És ha mindezt megcsináltad ezt keptad : EREDMÉNY (lehet majd...) 



 

Image Map készítése
 

A menü készítés másik módja az Image Map készítése. Ez abban különbözik az elöbb említett módszertõl, hogy itt nem több képbõl áll a menüpont, hanem egy képbõl. És ráadásul nem is vált képet amikor rámegyünk az egérrel, DE Viszint ez abból jó, hogy egy képen akár 10 helyet is kijelölhetünk kattintás céljából. De hogy mit is jelent ez ??

Elsõ lépés: Készíts egy képet, vagy hívj be egy Cool Képt (pl egy jó kis hölgyet:-)

Én inkább csináltam az Adobe Image Styler-jével. Lásd (kb 3 perc alatt raktam össze.. Ki*aszott jó ez a Adobe !)

1. Szóval ismét az elsõ lépések: File/New (képes példa) (képes példa)

2. Inzertáld be a képedet, hogy úgy magyarosan modjam:-) Insert/Image. Ekkor ezt látod (ha ki van jelölve a képed)(képes példa) Szép az írásom ? :-)

3. Kattints a Map gombra.(képes példa) A képen bejelöltem a legfontosabb helyeket, amiket kell használni. Jó ugye:-)

És kész is.



És ha mindezt megcsináltad ezt keptad : EREDMÉNY


 

A Többi Java Script funkció a Behavior Panelbõl elérhetõ, ha végignézted a fönti sorokat, akkor terveim szerint már fogod tudni, hogy kell egy kis Java Scriptet (A Behavior Panel bal felsõ "+" klikk és választás) akár képhez, akár szövegrészlethez hozzárendelni. Ha nem megy Írj ! 
De próbálkozz bátran, Úgy lehet a legjobban elsajátítani egy programot, ha Te jössz rá dolgokra
Sok Sikert !
No de egy kis Segítség még: (A behavior panel "+" -ára kattintva; a legfontosabbak) 

- Call Javascript: Ha rákattinr a kuncsaft a képedre, vagy a szövegedre egy Sriptet hív meg
- Check Browser - Böngészõ detektáló. Attól függ melyik olyan linkre küld téged
- Check Plugin - Plugin detektáló a Böngészõbe, mi is van feltelepítve
- Display Status Message - Alsó Sorba tudsz kiiratni dolgokat
- Got to URL - A beírt Webhwlyre küldi a Válalkozó Szellemû Kolegát
- Open Browser Window - Ablak magnyitó a megadott URL-lel. Minden opciót be lehet állítani
- Popup Message - Figyelmeztetõ szöveg kiiratása
- Swap Image - Az elõbb már megemlítetem a Menükészítésnél.

No és a TimeLine. Az idõzítõ. Itt bármelyik Behavior Java Scriptet tudod idõzííteni. Próbáld ki bátran.

- F9 . Kattints a Bevonalazott résznél a B jelû részére. Jobb klikk. Add Behavior. És kész is. Ha az Add Objektet vlasztod, akkor a Mozgó Layereket lehet megcsinálni vele. Ne felejtsd el az AutoPlay-t ill a Loop-ot beikszelni a jobb felsõ sarokban a Timelines panelen.

Ötletek:
Egy Ötlet Kezdõknek: 
- Készíts Sablont, és ezt hívd meg mindig, ha egy újabb oldalt akarsz készíteni, majd editáld meg és mentsd el más néven. Így garantáltan ugyan olyan stílus lesz az összes oldalon.
- Ha ez az elsõ lapod, akkor szerintem érdemes elõször kitalálnod egy Stílust magadnak. Ez lehet Kép vagy csak egy Szín összeállítása. Itt pl a Szöveg színére, A Linkek színére, A Látogatott Linkek színére, A Háttér színére.... gondolok. Nekem egy elég egyszerû, de szerintem a Célnak megfelelõ Stílusom van :-) 
Vigyázz !!! Ne rakj fel túl sok képet a lapodra, mert azt nem gyõzi majd kivárni a kuncsaft.:-)
- Ha Másolsz az egyik lapról a másikra (CTRL+C, CTRL+V), akkor figyelj az azonos kódolásra a Page Propertiesben (jobb klikk/Page Properties/Document Encoding) Ugyanis, ha nem figyelsz rá és különbözõ a kódolási eljárás, akkor elég érdekes dolgokat tudsz beszúrni az új dokumentumba, de nem azt amit az eredetibõl akartál volna.
- Vigyázz a hivatkozások írásánál: http://w3.swi.hu/kesro a jó írási mód és nem csak w3.swi.hu/kesro és ha azt akarod, hogy még klikkelhetõ legyen akkor ezt kell írnod.... http://w3.swi.hu/kesro
 

[image: image1.jpg]



Azt hiszem, hogy mindazok, akik valamelyik Windowst használják – legyen az 3.1, a 95 vagy az NT –, elõbb-utóbb találkoznak a Paint Shop Pro valamelyik verziójával, és sokan alkalmazzák is..
A legtöbben persze csupán bitmap képek megnézésére, konvertálására, jobb esetben kisebb alakításokra használják. Pedig a program ennél sokkal többet tud.

E sorozatunkban néhány olyan ötletet teszünk közzé, amelyek – bár önmagukban is felhasználhatók – elsõsorban azt a célt szolgálják, hogy minél alaposabban bemutathassuk a program tudását. Az itt bemutatásra kerülõ tippek Paint Shop Pro 4.12-vel készülnek. 

Mostanában úgyis divat a saját Web-lapok készítése, ezért e téma köré csoportosulnak az ötletek. És mivel a szép HTML oldalak alapja a szép háttér, kezdjük az alapoknál! Hiszen nagyon sokan kínálnak különbözõ háttérképeket, háttérmintákat, ám ezek többsége pénzbe kerül. És miért adjunk pénzt olyanra, amit mi is meg tudunk csinálni?

Az eszközök
Munkára fel! Indítsuk el a programot, majd itt álljunk is meg egy pillanatra! A programban négy nagyon fontos palettát, eszközcsoportot találunk. Az elsõ a Standard Toolbar, amelyen a legfontosabb funkciók ikonjait találjuk. A második a rajzeszközöket tartalmazó Tool Palette. A harmadik a Style Bar, amely az aktuálisan kijelölt eszköznek megfelelõen változik. Ezen tudjuk az adott rajz- vagy más eszköz tulajdonságait beállítani, megváltoztatni. Végül meg kell említeni a színválasztót, a Color Palette-et.

A színválasztó paletta három részbõl áll: legfelül a választható színeket, alatta az aktív színeket, legalul az aktuális színt találjuk. A középsõ részen található aktív színek közül a felsõ az elõtér- vagy festõszín, a hátulsó a háttérszín. Ezeket kétféle módon tudjuk megváltoztatni. Rákattinthatunk valamelyikre, majd a palettáról (a kép színeinek száma 256 vagy kevesebb), illetve a megjelenõ színválasztó ablakban kiválasztunk egy színt. Ha számszerûen is tudjuk a szín adatait (RGB vagy HSL), akkor kitöltjük a megfelelõ mezõket. Ez utóbbi ablak akkor is megnyílik, ha a paletta valamelyik színére duplán kattintunk, de ilyenkor nem csak az elõtér vagy a háttér színét változtatjuk meg, hanem a kép összes olyan pontjának színét, amely a paletta kiválasztott színével van kifestve.

Másik lehetõség, hogy kiválasztjuk a szemcseppentõ eszközt (a hatodik eszköz), majd a kép fölött mozgatjuk a kurzort. Ilyenkor a Color Palette legalsó részében láthatjuk, hogy milyen színû pont fölött áll az eszköz. Sõt, ha 256 (vagy kevesebb) színû kép fölött vagyunk, akkor azt is láthatjuk, hogy a színpalettán hányadik az adott szín. Ha ilyenkor a bal egérgombbal kattintunk, akkor azzal az aktuális színt kiválasztjuk elõtérszínnek, míg ha a jobb gombbal, akkor háttérszínnek. Speciális eset, amikor a kurzort a Color Palette felsõ harmada fölött mozgatjuk, e fölött ugyanis – a kiválasztott eszköztõl függetlenül – mindig a szemcseppentõ lesz az aktív szerszám. Megcserélni az elõtér- és a háttérszínt a legegyszerûbben a köztük levõ nyílra kattintva tudjuk.

Kezdjünk neki!
Elõször is hozzunk létre egy új képet. Ehhez válasszuk a File/New funkciót, vagy nyomjuk meg a [Ctrl N] billentyûkombinációt, esetleg kattintsunk a Standard Toolbar elsõ ikonjára. A megjelenõ ablakban mind a szélesség (Width), mind a magasság (Height) értékének adjunk meg 300-at, háttérszínnek (Background color) fehéret (White), képtípusnak (Image type) pedig TrueColort (16.7 Million Colors). Válasszuk ki az Image/Special Filters/Add Noise funkciót, majd állítsuk be a zajtípust véletlenszerûre (Random), a zaj nagyságát pedig 100%-osra (% Noise). Már ez sem néz ki rosszul, de most egy szürkeárnyalatos képre lesz szükségünk, ezért elõször a Colors/Grey Scale funkcióval átalakítjuk képünket, majd a Colors/Increase Color Depth/16 Million Colorsszal visszaállítjuk true colorra.




 HYPERLINK "http://www.freeweb.hu/kesro/psp/pict/psp0101.jpg" Ezzel el is jutottunk egy fontos ponthoz, mivel ez a kép lesz további ténykedéseink egy részének alapja. Ezért mentsük el (File/Save vagy [Ctrl S] vagy a lemezt ábrázoló ikon) például PCX (Version 5) – de mindenképpen true color, veszteségmentes – formátumban "alap" néven. Egyébként akár ez a kép vagy egy kevésbé "zajos" változata (nem 100%-ot kell megadni zajszintnek) is használható háttérként, de azért menjünk tovább.

Válasszuk ki az Image/Deformations/Motion Blur funkciót. Iránynak (Directions) adjunk meg egy tetszõleges szöget (az illesztés miatt javasolt egy 45-tel osztható érték, például 135 fok), míg intenzitásnak (Intensity) 40 képpontot, és már készen is vagyunk az elsõ hátterünkkel. Mentsük el a képet elõször PCX formátumban (például metal_1.PCX), hátha szükségünk lesz még rá. Viszont egy 300*300-as kép túl nagy háttérmintának, ezért az Image/Resize funkcióval kicsinyítsük le 150*150-esre, és az Image/Normal Filters/Sharpen vagy Sharpen More funkcióval élesítsük ki egy kicsit. Így mentsük el (File/Save As vagy [F12]) JPG formátumban, lehetõleg ugyanazon a néven, a kavarodások elkerülése végett.

Most töltsük vissza az ALAP.PCX-et, vagy ismét végezzük el az elsõ öt lépést. Az elõtérszínt állítsuk be fehérre, majd válasszuk ki az Image/Special Effects/Hot Wax Coating funkciót. Hmmm. Érdekes, nem? Mentsük el, például STONE.PCX néven. Ugye azok, akik az ALAP.PCX-et töltötték vissza, nem a File/Save-et vagy a [Ctrl S]-t használták a mentéshez! Ha ezt akarjuk háttérképnek használni, akkor az elõbb már bemutatott módon kicsinyítsük le (Resize + Sharpen), majd mentsük el JPG formátumban. (Ezt a mûveletet, részben helytakarékossági okokból, részben azért, mert egy idõ után nagyon unalmas lenne, nem fogom minden egyes alkalommal elismételni.)

Ismét töltsük vissza az ALAP.PCX-et, és az elõtérszínt állítsuk be úgy, hogy piros (Red), zöld (Green), kék (Blue) értékei 230, 220, illetve 60 legyenek, majd használjuk a már ismert Image/Special Effects/Hot Wax Coating funkciót. Ezután kétszer-háromszor hívjuk meg a szintén bemutatott Image/Deformations/Motion Blurt úgy, hogy válasszunk egy tetszõleges (lehetõleg 45-tel osztható) szöget, amelyet a második és a harmadik esetben már változatlanul hagyunk, valamint 40 képpontos intenzitást. Az elkészült képet mentsük el metal_2.PCX néven.

Induljunk ismét az ALAP.PCX-tõl. Az Image/Deformations/Motion Blur funkciónak állítsunk be 90 fokos irányt és 5 képpontos intenzitást. Ezután válasszuk újra ezt a függvényt, ám ezúttal 180 fokos iránnyal és 40 képpontos intenzitással. Erre jön egy kis Image/Edge Filters/Edge Enhance More, majd egy kis Image/Special Filters/Emboss. Az így elkészült kép egészen jól néz ki, de sokkal szebb is lehetne, ha nem lenne szürke. Ehhez elõször is válasszunk ki egy színt. Ez úgy történik, hogy az elõtér- vagy a háttérszínre kattintunk, majd az ablakban beállítunk egy nekünk tetszõ színt. Ha a kis keretben látható árnyalat elnyeri tetszésünket, akkor megjegyezzük vagy leírjuk a Hue és a Sat (Saturation) értékeit, majd megnyomjuk a Cancel gombot, hacsak nem akarjuk valamiért kiválasztani az adott színt. Ezután kiválasztjuk a Colors/Colorize ([Shift L]) mûveletet, majd a Hue és a Saturation mezõkbe beírjuk a megjegyzett értékeket. Az OK gomb megnyomása után máris gyönyörködhetünk mûvünkben. Ezt a mûveletsort nem fogom minden egyes alkalommal elmondani, de ettõl függetlenül bármely képet, hátteret átszínezhetünk ezzel az eljárással.

Töltsük be újra az ALAP.PCX-et, és állítsuk az elõtérszínt fehérre. Használjuk az Image/Deformations/Motion Blur funkciót elõbb 135 fokos és 40 képpontos, majd közvetlenül utána 45 fokos és 40 képpontos beállítással. A kép úgy néz ki, mintha egy szürke massza lenne, pedig nem teljesen az. Ez azonnal kiderül, amint kétszer "ráengedjük" az Image/Special Effects/Hot Wax Coating-ot. Ezt már érdemes elmenteni!

ALAP.PCX


 HYPERLINK "http://www.freeweb.hu/kesro/psp/pict/psp0102.jpg" Ismét térjünk vissza az alapokhoz (), viszont az elõtérszínt állítsuk át halványszürkére (R:192, G:192, B:192). A már unalomig ismert Motion Blurt megint kétszer fogjuk használni, elõször 90 fok, 20 képpont, majd 45 fok, 20 képpont beállítással. És ezután mi jön? Igen, a Hot Wax Coating, és már menthetjük is az újabb háttérképünket.

A változatosság kedvéért töltsük be újra az ALAP.PCX-et, és hagyjuk az elõtérszínt fehéren. Egymás után háromszor használjuk az Image/Normal Filters/Blur More funkciót, majd a Hot Wax Coatingot. Hát nem gyönyörû?!

Újabb hátterünk mindössze annyiban tér el az elõzõtõl, hogy a háromszori Blur More után nem a Hot Wax Coatingot, hanem az Image/Special Filters/Embosst használjuk, és máris van egy újabb képünk.

ALAP.PCX


 HYPERLINK "http://www.freeweb.hu/kesro/psp/pict/psp0103.jpg" Az ilyen "fal típusú" háttereinket zárjuk a legegyszerûbbel. Az -rõl indulunk megint, és ezúttal az Image/Special Filters/Mosaic függvényt használjuk, amelynél blokkméretnek mind szélességnek, mind magasságnak 5-öt adunk meg, majd az elõzõhöz hasonlóan használjuk az Image/Special Filters/Embosst.

Most egy kicsit kevésbé "sûrû" képre van szükségünk, ezért hozzunk létre egy új képet (300*300-as, fehér háttérszín és 16,7 millió szín), és hagyjuk fehéren az elõtérszínt, vagy ha elállítottuk, akkor állítsuk vissza. Ezután a legelején már használt Image/Special Filters/Add Noise függvénynek állítsunk be Uniform típust és 10%-os zajszintet. Ha megvan, akkor az Image/Normal Filters/Sharpen mûvelettel még jobban fehérítsük ki, majd használjuk a már szinte elfelejtett Hot Wax Coatingot. Már így sem néz ki rosszul, de háromszori Image/Normal Filters/Sharpen More még kellemesebbé teszi.

Ismét hozzunk létre egy fehér, 300*300-as true color képet, viszont az elõtérszínt állítsuk be sötétbarnára (például R:160, G:80, B:0). Az Add Noise függvényt ezúttal Random, 25% beállítással futtassuk le, majd a képet szürkítsük el (Colors/Grey Scale, Colors/Increase Color Depth/16 Million Colors). Most használjuk a Hot Wax Coatingot, majd a Motion Blurt 90 vagy 180 fokos, 40 képpontos beállítással. A faszerû hatás elkészítéséhez használjuk még kétszer vagy háromszor a Sharpen More-t.

 
 

 

Néhány minta háttérminta:





 HYPERLINK "http://www.freeweb.hu/kesro/psp/psp1/darkwood.htm" 

 INCLUDEPICTURE "file:///C:/WINDOWS/TEMP/msoclip1/05/clip_image009.jpg" \* MERGEFORMATINET 



 HYPERLINK "http://www.freeweb.hu/kesro/psp/psp1/metal_1.htm" 

 INCLUDEPICTURE "file:///C:/WINDOWS/TEMP/msoclip1/05/clip_image011.jpg" \* MERGEFORMATINET 



 HYPERLINK "http://www.freeweb.hu/kesro/psp/psp1/metal_2.htm" 

 INCLUDEPICTURE "file:///C:/WINDOWS/TEMP/msoclip1/05/clip_image013.jpg" \* MERGEFORMATINET 



 HYPERLINK "http://www.freeweb.hu/kesro/psp/psp1/painted.htm" 

 INCLUDEPICTURE "file:///C:/WINDOWS/TEMP/msoclip1/05/clip_image015.jpg" \* MERGEFORMATINET 



 HYPERLINK "http://www.freeweb.hu/kesro/psp/psp1/sandston.htm" 

 INCLUDEPICTURE "file:///C:/WINDOWS/TEMP/msoclip1/05/clip_image017.jpg" \* MERGEFORMATINET 







 HYPERLINK "http://www.freeweb.hu/kesro/psp/psp1/stucco_4.htm" 

 INCLUDEPICTURE "file:///C:/WINDOWS/TEMP/msoclip1/05/clip_image027.jpg" \* MERGEFORMATINET 



 HYPERLINK "http://www.freeweb.hu/kesro/psp/psp1/stucco_5.htm" 

 INCLUDEPICTURE "file:///C:/WINDOWS/TEMP/msoclip1/05/clip_image029.jpg" \* MERGEFORMATINET 



 HYPERLINK "http://www.freeweb.hu/kesro/psp/psp1/stone.htm" 

 INCLUDEPICTURE "file:///C:/WINDOWS/TEMP/msoclip1/05/clip_image019.jpg" \* MERGEFORMATINET 



 HYPERLINK "http://www.freeweb.hu/kesro/psp/psp1/stucco_1.htm" 

 INCLUDEPICTURE "file:///C:/WINDOWS/TEMP/msoclip1/05/clip_image021.jpg" \* MERGEFORMATINET 



 HYPERLINK "http://www.freeweb.hu/kesro/psp/psp1/stucco_2.htm" 

 INCLUDEPICTURE "file:///C:/WINDOWS/TEMP/msoclip1/05/clip_image023.jpg" \* MERGEFORMATINET 
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Múlt hónapban a hátterek készítésénél hagytuk abba képalkotó tevékenységünket.
Mivel a változatosság gyönyörködtet, készítsünk e havi bemutatónkhoz is egy szép háttérmintát, majd folytassuk a szöveg effektusokkal!

Hozzunk létre egy 300*300-as, fehér hátterû, true color (16 Million Colors) képet (File -> New vagy [Ctrl N]). Válasszuk ki az Image -> Special Filters -> Add Noise funkciót, majd azon belül a Uniform típust és 100%-os zajnagyságot. A kissé színes képet alakítsuk át szürkeárnyalatossá (Colors -> Gray Scale), majd vissza true colorrá (Colors -> Increase Color Depth -> 16 Million Colors).

Errõl a képrõl készítsünk egy másolatot úgy, hogy elõbb az Edit -> Copyval kimásoljuk a vágólapra, majd az Edit -> Paste -> As New Image-dzsel létrehozzuk a másolatot. Ez így leírva kicsit hosszú, de a [Ctrl C], majd a [Ctrl V] billentyûkombinációval pillanatok alatt elkészíthetõ a másolat.

Ha már úgyis a másolat az aktív, akkor folytassuk ezzel! Az Image -> Deformations -> Motions Blur funkcióval "kenjük el" a képet 0 fokos irányt és 40 pixeles intenzitást megadva. Most válasszuk ki az eredeti képet! Azok, akik jobban kedvelik a billentyûzetet, mint az egerészést, használhatják erre a [Ctrl Tab] kombinációt. Kenjük el ezt a képet is, ám ezt vízszintesen, 90 fokos irányt megadva.




 HYPERLINK "http://www.freeweb.hu/kesro/psp/pict/psp0207.jpg" Most jön a "poén". Jelöljük ki a teljes képet a Selections -> Select All funkcióval, vagy még a [Shift A]-t megnyomva. A kijelölést tegyük félig átlátszóvá a Selections -> Modify -> Overall Opacity-vel ([Ctrl Y]).

A "félig" ez esetben szó szerint értendõ, vagyis átlátszóságnak adjunk meg 50%-ot. Most ezt másoljuk ki a vágólapra (Edit -> Copy vagy [Ctrl C]), majd válasszuk ki a másolatot, és tegyük rá erre az Edit -> Paste -> As New Selection ([Ctrl E]) funkcióval.

[image: image48.jpg]


A pontos illesztés némi kézimunkát igényel, mert nekünk kell megadnunk, hogy a program pontosan hova tegye a kiválasztott részt. Ehhez addig kell mozgatnunk az egeret a kép fölött, amíg a programablak alján található állapotsorban a legelsõ koordinátapár (0,0) nem lesz, majd ha ezt sikerült elérnünk, kattintsunk egyet. Szüntessük meg a kijelölést a Selections -> Select None-nal vagy a [Shift N] megnyomásával. Háromszori Image -> Normal Filters -> Sharpen More, aztán a múlt hónapban bemutatott átszínezés (Colors -> Colorize vagy [Shift L]), és már készen is vagyunk. És bár a Paint Shop Pro szerint több mint 25 ezer színben pompáznak a pixelek a képen (Colors -> Count Colors Used), nyugodtan alakítsuk át a képet 256 színûvé Colors -> Decrease Color Depth -> 256 Colors, Palette: Optimized és Reduction method: Nearest color beállításokkal. Végül mentsük el GIF formátumban. Az eredeti képet eldobhatjuk, a továbbiakban nem lesz rá szükségünk.

Látványos feliratok
Ha Web-oldalunkra szeretnénk néhány szép feliratot is, akkor vagy egy szép betûtípust használunk – ám ekkor valahogy gondoskodnunk kell (kellene) arról, hogy az összes olvasó gépén telepítve legyen az adott font –, vagy grafikaként helyezzük el az oldalunkon. Természetesen mi most az utóbbi megoldással foglalkozunk.

[image: image15.jpg]felifa;




Kezdjük egy egyszerû neon effektussal! Ehhez hozzunk létre egy 400*100 képpont méretû, fekete hátterû, 256 szürkeárnyalatos – 256 Grays – képet, és állítsuk fehérre az elõtérszínt. Nincs akadálya, hogy 16 millió színû képpel dolgozzunk, de most teljesen felesleges. Válasszuk ki az eszközök közül az "A"-t, és kattintsunk a kép tetszõleges pontjára. A megjelenõ ablakban állítsuk be a szöveg paramétereit: lehetõleg egy "kerekebb" betûtípust (például Vogue) és akkora betûméretet, amellyel az alulra beírt szöveg el fog férni a képen, valamint kapcsoljuk be az élsimítást (Antialias) és a "lebegtetést" (Floating).

A szöveget rakjuk le a kép közepén, majd szüntessük meg a kijelölést: Selections -> Select None vagy [Shift N], vagy kattintsunk az egér jobb gombjával a képre. Ha ezzel megvagyunk, akkor ízléstõl függõen egy-három alkalommal használjuk az Image -> Normal Filters -> Blur More-t. Válasszuk a Colors -> Solarize funkciót és a küszöbértéknek – Threshold – adjunk meg 125-öt. Végül a már jól ismert Colors -> Colorize funkcióval színezzük át a feliratot, és mentsük el a képet. Érdekes megnézni, hogy ez a funkció hogyan alakítja át "röptében" a kép palettáját.

[image: image16.jpg]



A következõ felirathoz hozzunk létre egy 400*100-as, fehér hátterû, true color képet. Az elõtérszínt cseréljük ki kékre, vagy egy másik tetszõleges – lehetõleg sötétebb – színre. Írjunk egy tetszõleges szöveget, tetszõleges betûtípussal a kép közepére. A háttéreffektusnál már említett Selections -> Modify -> Overall Opacity funkció ([Ctrl Y]) ablakában 20%-ot megadva halványítsuk le a feliratot. Szüntessük meg a kijelölést ([Shift N]), majd az Image -> Special Effects -> Hot Wax Coatinggal fejezzük be a mûveletsort.

[image: image17.jpg]3D korvenal




Az újabb effektushoz egy szokásos méretû (400*100), fehér, true color alapra lesz szükségünk. Elõtérszínnek válasszunk valami sötététet. Teljesen mindegy, hogy milyent, nem ettõl függ a végsõ szín. A háttérszín azonban legyen mindenképpen fehér. A szöveget valami vastag betûvel írjuk a kép közepére. A Selections -> Modify -> Feather funkcióval ([Ctrl H]) kicsit növeljük meg a kijelölés határát (Feather: 15). Most válasszuk ki a szöveg eszköz feletti (melletti) festékes bödönt, állítsuk be a toleranciát 200-ra (az alapbeállítás szerinti RGB Value és a Solid Color marad), és a jobb gombbal kattintsunk valahol a szövegen.

Szüntessük meg a kijelölést, és állítsuk át az elõtérszínt halványszürkére (RGB – 200,200,200). Ezután használjuk a már jól ismert Image -> Special Effects -> Hot Wax Coatingot, majd a Colors -> Adjust -> Brightness/Contrast funkcióval ([Shift B]) eltüntetjük a szürke hátteret. Ehhez állítsunk be Brightnessnek 25-öt és Contrastnak 0-t. Az Image -> Normal Filters -> Sharpen vagy Sharpen More funkcióval kicsit kontrasztosabbá tesszük az egészet, végül a Colors -> Colorize-zel a kívánt színûre színezzük.

[image: image18.jpg]Hattexvilugitas




Ismét egy fehér, 400*100-as, true color kép lesz a kiindulási helyzet, amelyre tetszõleges sötét színnel ráírjuk a kívánt szöveget. A kijelölést ilyenkor úgy a legegyszerûbb megszüntetni, hogy elõször a bal gombot megnyomjuk a szöveg elhelyezéséhez, majd rögtön utána a jobb gombot a kijelölés megszüntetéséhez. Ezután háromszor-ötször használva az Image -> Normal Filters -> Blur More-t elkenjük a feliratot, majd az Image -> Edge Filters -> Find Edges-zel szinte teljesen eltüntetjük. Ahhoz, hogy újra jól látható legyen, használjuk a Colors -> Histogram Functions -> Stretch-et ([Shift T]), majd a Colors -> Colorize-zel (lehetõleg 255-ös Saturation értéket használva) átszínezzük.

Az így készült feliratok nagyon jól illenek az X-akták stílusú oldalakhoz. Például egy kis Java-scriptes betéttel nagyon látványos menüt készíthetünk, ha minden menüponthoz készítünk két különbözõ színû képet, és a script gondoskodik arról, hogy a kurzor alatti menüpont mindig átszínezõdjön.

[image: image19.jpg]



Az e havi "óra" befejezéseként vigyük a feliratunkat a víz alá. Ehhez hozzunk létre egy 400*100-as true color képet, amelynek fekete a háttere. Ezután fogjuk meg a Paint Brushes nevû ecsetet, és állítsuk be úgy, hogy típusa (Brush type) Normal, mérete 100, körvonala (Shape) kör alakú (Round), míg a textúra (Paper texture) felhõs (Clouds) típusú legyen. Festõszínnek válasszunk fehéret, majd óvatosan "spricceljük" tele a képet. A spriccelés ezúttal azt jelenti, hogy folyamatos kattintásokkal festjük ki a képet úgy, hogy a közepe világosabb, a széle kicsit sötétebb legyen. Világosabb attól lesz, hogy csak kicsit mozdítjuk el a kurzort az ismételt kattintás elõtt. Figyelem: az ecset használata során – ez esetben – az egeret tilos lenyomott egérgombbal húzni!




 HYPERLINK "http://www.freeweb.hu/kesro/psp/pict/psp0208.jpg" Ezután az elõtérszínt átállítjuk feketére, és egy vastagabb betûtípussal (a példán 48 pontos félkövér Litograph) elkészítjük a kép közepére a feliratot. Megint kiválasztjuk az ecsetet, átállítjuk az e lõtérszínt fehérre, és a szöveget úgy festjük ki, hogy teljesen beleolvadjon a háttérbe. Ha készen vagyunk ezzel, kicseréljük az elõtérszínt valami élénk színûre (például cián, neonzöld, sárga stb.), majd kiválasztjuk a festékszórót, és beállítjuk a jellemzõit: méret = 30, körvonal = Round, Opacity = 50, Paper texture = Clouds. A festékszóróval átfestjük a feliratot. Szerencsére most nem kell kattintgatnunk, elegendõ, ha nyomva tartott egérgombbal néhányszor végigmegyünk a teljes szövegen. 
Ha már szép színes, akkor megszüntetjük a kijelölést ([Shift N]). Most már a Paint Shop Pro dolgozik: elõször Image -> Special Filters -> Dilate, majd Image -> Normal Filters -> Blur More, ezután a fehér színû elõtérrel Image -> Special Effects -> Hot Wax Coating, végül Colors -> Adjust -> Red/Green/Blue ([Shift U]), Red = 0, Green = 40 és Blue = 100 beállítással.

Minden esetben megéri megnézni, hogy a 256 színûre konvertált kép minõsége mennyire romlik. Ha kell, utána megnyomjuk a [Ctrl Z] billentyûkombinációt.
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Sorozatunk elõzõ részében a látványos feliratok készítésével foglalkoztunk. Most néhány látszólag bonyolultabb effektust próbálunk ki.
Sokszor mondjuk egy-egy szöveg elhangzásakor, hogy aranyba kéne foglalni. Elõttünk a lehetõség! A Paint Shop Pro elindítása után hozzunk létre (File -> New, vagy [Ctrl N], avagy a legelsõ ikon a Standard Toolbaron) egy 400*100-as, true color (16,7 millió színû), fehér hátterû képet. Ezután – vagy még ez elõtt – állítsunk be háttérszínnek fehéret, elõtérszínnek pedig világosszürkét, például a színek beállítóablakában a fehértõl kettõvel balra található színt.

Ezután válasszuk ki a szöveg eszközt, és hozzuk létre a feliratot. A megjelenõ beállítóablakban ne felejtsük el bekapcsolni az elsimítást (Antialias) és a "lebegtetést" (Floating). Az effektushoz nagyon jól használhatók a vékonyabb vonalú betûk (például a Technical betûtípus dõlt, félkövér változata). Betûméretnek válasszunk akkorát, amekkorával a felirat "kényelmesen" elfér a képen. Ehhez esetleg több kísérletre lesz szükség, amelyek között a [Delete] billentyûvel törölhetjük a rossz méretû szöveget. A szokásostól eltérõen a feliratot ne pont középre, hanem egy kicsit feljebb és balra helyezzük el.
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A kijelölést ne szüntessük meg, hanem inkább növeljük meg egy kicsit a Selections -> Modify -> Feather funkcióval ([Ctrl H]) úgy, hogy a Feather Selections ablakban 7 és 10 közötti értéket adunk meg. Ezután használjuk a sorozat elõzõ két részébõl már jól megismert Image -> Special Effects -> Hot Wax Coatingot. A képet – fakultatív módon – sötétebbé tehetjük a Colors -> Adjust -> Brightness/Contrast ([Shift B]) ablakában -15% világosság (esetünkben sötétség) és +50% kontraszt értéket megadva.

A mostanáig szürke képet két módon is színesíthetjük. Az egyik: a Colors -> Adjust -> Red/Green/Blue ([Shift U]) ablak mezõibe rendre 60, 20 és 0 értékeket gépelünk be. A másik: a szintén már sokszor használt Colors -> Colorize ([Shift L]) funkcióban a színárnyalatnak (Hue) 32-õt, a telítettségnek (Saturation) pedig 255-öt adunk meg.

Végül a térbeliséget a vetett árnyékkal hangsúlyozzuk ki. Az Image -> Special Effects -> Add Drop Shadow funkció kiválasztása után megjelenõ ablakban árnyékszínnek (Color) feketét, homályosságnak (Opacity) 200-at, elmosásnak (Blur) 18-at, vízszintes és függõleges eltolásnak (Vertical és Horizontal) pedig egyaránt 5-öt adunk meg.

Behorpadt felirat
Még ennél is egyszerûbb elkészíteni egy horpadt betûkbõl álló feliratot. Kezdjük megint a munkát egy fehér, true color, 400*100 képpontos képen. Állítsuk mind az elõtér-, mind a háttérszínt fehérre, és így hozzuk létre a vastag betûtípusból álló szövegünket a kép közepén. A szokásosnál kicsit nehezebb lesz szemmérték után elhelyezni a feliratot, ugyanis a mozgatás idejére a Paint Shop Pro eltünteti a kijelölõ keretet, anélkül meg csak a fehér betûket látjuk fehér alapon.
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Ha sikerült elhelyeznünk a szöveget, akkor használjuk kétszer az Image -> Special Effects -> Cutout effektust. Mindkét esetben legyen kikapcsolva a Fill interior with color kapcsoló (ennek megfelelõen teljesen mindegy, hogy mi van kiválasztva az Interior color mezõben). Az árnyék színe (Shadow color) legyen fekete (Black), a homályosság (Opacity) 180, az elmosás (Blur) maximális, vagyis 36. Az elsõ esetben a vízszintes és a függõleges eltolás (Vertical és Horizontal) legyen 3;3, míg a második esetben -3;-3. Ha megvagyunk ezzel, akkor jön a "kihagyhatatlan" Image -> Special Effects -> Hot Wax Coating, majd az Image -> Special Filters -> Embossszal benyomjuk a betûket. Az effektust az átszínezéssel (Colors -> Colorize vagy [Shift L]) fejezzük be, amelynél a telítettségnek (Saturation) kisebb értéket (<100) adjunk csak meg, hogy a szöveg pasztell árnyalatú maradjon.

Édes szavak
Ismét hozzunk létre egy 400*100-as, fehér hátterû, true color képet. A háttérszínt hagyjuk fehéren, az elõtérszínt viszont állítsuk át világosbarnára (Red: 255, Green: 128, Blue: 0). A középre elhelyezendõ szöveghez most használjunk valami vastagabb betûtípust, például egy félkövér Impactot.

Mivel az általunk használandó Chisel effektus a kijelölt területrõl kifelé fejti ki hatását, mi viszont a szövegen belül szeretnénk használni, ezért invertálnunk kell a kijelölést a Selections -> Inverttel ([Shift V]), majd meg kell hívnunk az Image -> Special Effects -> Chiselt. A megjelenõ ablakban méretnek (Size) hagyjuk meg az alapbeállítás szerinti 20-at, de a kapcsolót az átlátszóról (Transparent) váltsuk át a háttérszín (Background Color) állásra.

Ha valaki a funkciókat billentyûzetrõl – az [Alt] és az aláhúzott betûk együttes megnyomásával – választja ki, azt meglepetés fogja érni. Ugyanis az Image -> Special Effects menüben a Chisel és a Hot Wax Coating funkcióhoz egyaránt a [H] betû tartozik, és a Paint Shop Pro valamiért az utóbbit részesíti elõnyben, vagyis marad a Chisel sorának lefelé nyíllal történõ kijelölése, majd az [Enter] megnyomása vagy az "egerészés".
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A vésés (a chisel jelentése itt nem becsap, bepaliz, hanem vésõ, vés) után ismét invertáljuk a kijelölést (Selections -> Invert vagy [Shift V]), majd az Image -> Normal Filters -> Blur More-ral elkenjük egy kicsit a szöveget. A már-már szokásosnak mondható Image -> Special Effects -> Hot Wax Coating effektust (ez esetben használható az [Alt I, P, H] kombináció) követi egy kis élesítés, amelyhez az Image -> Normal Filters menü Sharpen vagy Sharpen More funkcióját egyaránt használhatjuk. Igény esetén vetett árnyékkal hangsúlyozhatuk a térbeliséget. Az árnyék beállításai megegyeznek az elõzõ effektusnál bemutatottakkal.

Vizes paca a lapon
A múlt hónapban már volt egy vizes effektusunk, de most ismét jöjjön egy nedves felirat. Ehhez elõször is szükségünk lesz a szokásos kiinduló képre (400*100*24 bit, fehér háttér). Ezen helyezzük el a fekete, vékony, lehetõleg írott betûkbõl álló feliratunkat. Változtassuk meg az elõtérszínt fehérre, majd válasszuk ki az ecset eszközt (Paint Brushes). Ennek változtassuk meg a beállításait úgy, hogy az ecset típusa (Brush type) legyen normál, a mérete (Size) legyen 100 képpont (vagy legalábbis akkora, amekkora a szövegünk), az alakja (Shape) legyen négyszögletes (Square), a papír mintája (Paper texture) pedig legyen márványmintás (Marble). Végül ezzel az ecsettel húzzunk végig egyenletesen a szövegen egyszer vagy kétszer.
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Ha átfestettük a szöveget, akkor invertáljuk a kijelölést (Selections -> Invert vagy [Shift V]), majd használjuk a fentebb már bemutatott Image -> Special Effects -> Chiselt, de ezúttal nem háttérszín, hanem átlátszó (Transparent) beállítással. Az így elkészült szöveget elvékonyítjuk az Image -> Special Filters -> Dilate funkcióval, de elõbb szüntessük meg a kijelölést ([Shift N]).

A vékonyított szöveget egy kicsit elkenjük az Image -> Normal Filters -> Blur More-ral, majd jöhet az elmaradhatatlan Image -> Special Effects -> Hot Wax Coating. Végül a Colors -> Adjust -> Red/Green/Blue ([Shift U]) ablakban 0;40;100 vagy a Colors -> Colorize ([Shift L]) ablakban 140;255 értékeket megadva készítjük el a felirat végsõ formáját.

Ragyogás
Mai leckénket egy érdekes – és a szokásosnál kicsit bonyolultabb – effektussal zárjuk. Az effektus több melléktermékét is felhasználhatjuk késõbbi munkák során.

A kezdés a szokásos: egy fehér hátterû, true color, 400*100-as üres lap. A háttérszín továbbra is legyen fehér, az elõtéré pedig fekete. A használt betûtípus ne legyen nagyon vékony vonalú, de más megkötés nincs. A mellékelt példában Freeform 721 Blacket használtam, de szinte bármilyen fontot választhatunk.

Az eddig megszokottaktól eltérõen ezúttal a szöveg elhelyezése után szüntessük meg a kijelölést. Ezt megtehetjük a Selections -> Select None funkcióval, vagy a [Shift N] billentyûkombinációval, de a legegyszerûbb, ha a jobb egérgombbal a kép tetszõleges pontján kattintunk. A betûk vonalát megvastagítjuk az Image -> Special Filters -> Erode funkcióval, majd az Image -> Edge Filters -> Find Edges-zel létrehozzuk az eredeti szöveg fekete alapon fehér körvonalas változatát.

Ahogy említettem, ennek az effektusnak több hasznos "mellékterméke" is lesz. Íme az elsõ, hiszen látható, hogy két lépéssel hogyan készíthetünk egyszerû "outline" típusú feliratot. De most nem ez a célunk, ezért menjünk tovább.
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Jelöljük ki a fehér részeket! Ezt két módon tehetjük meg. Az egyik, hogy fogjuk a "varázspálcát" és a [Shift] állandó nyomvatartása mellett addig kattintgatunk a szöveg körvonalán, amíg az egészet kijelöljük. Ennél kicsit egyszerûbbnek és biztosabbnak tûnik a másik megoldás. Kijelöljük az egész képet (Selections -> Select All vagy [Shift A]), majd a kijelölésbõl kihagyjuk a fekete részeket a Selections -> Modify -> Transparent Color ([Ctrl T]) funkcióval, melynek beállítóablakában átlátszó színnek elõtérszínt (Foreground Color) vagy feketét (Black), tûréshatárnak (Tolerance) nullát adunk meg. A kijelölést kissé megvastagítjuk a Selections -> Modify -> Feather ([Ctrl H]) segítségével. Attól függõen, hogy milyen széles "udvart" akarunk a végén, és hogy milyen széles betûtípust választottunk az elején, adjunk meg a Feather ablakban 5 és 10 közötti értéket.

Most jön a "varázslás" második fele. Ugyanis lehetõségünk van egyszínû vagy színátmenetes kifestésre is. Elõbbi esetben válasszunk egy tetszõleges színt elõtérszínnek, míg a második esetben mind az elõtér-, mind a háttérszínt állítsuk át a kívánt színátmenetnek megfelelõn. Válasszuk ki a Flood Fill eszközt (festékes kanna), tûréshatárnak adjunk meg 200-at, a festés módjának pedig vagy Solid Colort, vagy valamelyik színátmenetet (Linear, Rectangular, Sunburst vagy Radial Gradient). Utóbbi beállítások valamelyikénél az Options gombra kattintva beállíthatjuk a kifestés irányát vagy eltolását. Ha minden beállítással megvagyunk, akkor kattintsunk négyszer-ötször a szöveg körvonalára. Megint elmondhatjuk, hogy ez sem rossz – sõt –, ám nem ez a végcél.

Szép színeinket elõbb kifakítjuk az Image -> Normal Filters -> Blur More funkció nyolcszor-tízszer történõ alkalmazásával (a legegyszerûbb az [Alt I, N, L] billentyûkombinációt használni ilyenkor), majd egy kicsit "kifényezzük" a Colors -> Adjust -> Red/Green/Blue-val ([Shift U]) úgy, hogy mindhárom mezõbe 100-at írunk be. Ezután megszüntetjük a kijelölést ([Shift N]), az elõtérszínt visszaállítjuk feketére, majd ugyanazt a szöveget, ugyanazokkal a beállításokkal elhelyezzük ugyanoda, ahova eredetileg is tettük. Ezt csinálhatjuk szemre, de ha valaki nem bízik magában, az az elsõ esetben jegyezze meg vagy írja le a szöveg pozícióját, amit az állapotsor bal szélén olvashat le. Végül ismét megszüntetjük a kijelölést ([Shift N]), és az Image -> Special Filters -> Dilate-tel összemossuk a színes körvonalat a fekete szöveggel.
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Sorozatunkat feliratokkal, majd néhány más, webes objektum elkészítésével folytatjuk. Mivel egy-egy oldalon nem csak háttér és feliratok vannak, lesz még tennivalónk.
A különbözõ objektumok közül a gombokkal folytatjuk a sort, de azért még befejezzük betûvetõ tevékenységünket:

Fára írt szöveg
E havi elsõ feliratunkat fára fogjuk írni. Ehhez hozzunk létre egy fekete hátterû, 400*100 képpontos true color képet. A háttérszínt állítsuk át feketére, az elõtérszínt pedig barnára (R: 170, G: 85, B: 0). Helyezzük el a kép közepén a lehetõ legvastagabb betûtípussal (a példában 42 pontos Stencil) írt szövegünket, és hagyjuk kijelölve.

Válasszuk ki a Flood Fill eszközt (festékes kanna), állítsuk a toleranciát (Tolerance) 200-ra, vagy egyszerûen kapcsoljuk ki a határfigyelést (Match mode: None), majd az egér jobb gombjával kattintsunk a szövegre. Így most van egy fekete alapon fekete színû szövegünk, melynek csak a határvonalát látjuk a kijelölés miatt.
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Válasszuk ki a Paint Brushes eszközt (egy ecset), és állítsuk be a paramétereit a következõkre: Brush type: Normal, Size: 30, Shape: Round, Paper texture: Woodgrain. Ezzel az ecsettel húzzunk végig egyszer, esetleg kétszer a szövegen, invertáljuk a kijelölést (Selections -> Invert vagy [Shift V]), majd a szöveg környezetét is fessük át úgy, hogy a betûk beleolvadjanak a háttérbe.

Ha ez megvan, akkor ismét invertáljuk a kijelölést, hogy újra a szövegünk legyen kijelölve. Használjuk az Image -> Special Effects -> Cutout effektust úgy, hogy kikapcsoljuk a Fill interior with color kapcsolót (ennek megfelelõen ugye mindegy, hogy mire van állítva az alatta található Interior color mezõ), az árnyék színét (Shadow color) beállítjuk fehérre (White), a homályosságot (Opacity) 50-re, az elmosást (Blur) 5-re, a függõleges (Vertical) és a vízszintes (Horizontal) eltolást pedig egyaránt 2-re.

Ha ez kész, akkor újra meghívjuk a Cutout funkciót, és átállítjuk az árnyék színét feketére (Black), a függõleges és a vízszintes eltolást pedig -2-re (mínusz kettõre). Végül az Image -> Special Effects -> Add Drop Shadow effektussal kicsit "kiemeljük" a szöveget a fa síkjából. Ehhez használjunk fekete árnyékszínt, 200-as átlátszatlanságot, 36-os elmosást és 4 képpontnyi függõleges és vízszintes eltolást.

Ha a kifestésnél ecsetmintának nem a fa mintát (Woodgraint), hanem valamelyik másikat választjuk, és az elõtérszínt a választott mintához igazítjuk (például téglát – Large, Medium vagy Small Bricks – és vörös színt, vagy kék színt és felhõket stb.), akkor ugyanezekkel a lépésekkel téglafalra vagy felhõs égre írhatunk.

Perspektivikus árnyék
Effektusaink létrehozásához már többször használtuk – az egyébként önállóan is nagyon jól alkalmazható – Add Drop Shadow funkciót. Ez a kijelölt rész (legyen az egy téglalap, egy ellipszis vagy egy szöveg) vetett árnyékát készíti el a megadott paraméterek szerint. Mi van akkor, ha nem vetett, hanem perspektivikus árnyékra van szükségünk? Akkor azt bizony kézzel kell megcsinálnunk!
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Hozzunk létre egy az eddigieknél kétszer magasabb, 400*200-as true color képet, amelynek háttérszíne megegyezik Web-lapunk háttérszínével (vagy annak a lapnak, képnek a háttérszínével, amelyre a szöveget tenni akarjuk). Erre a képre írjuk feketével középre a szöveget. (A bemutatott effektus sajnos nem igazán alkalmazható olyan betûkön, amelyeknek lelógó részei vannak, vagyis kerülnünk kell a p, q, g, j és y karaktert.)

Ezután válasszuk ki a Flood Fill eszközt, és állítsuk be úgy, hogy mindent befessen, vagyis vagy a toleranciát állítsuk a maximális 200-ra, vagy a Match mode-ot None-ra, és a kifestés típusa (Fill style) lineáris színátmenet (Linear Gradient) legyen. Biztos, ami biztos: az Options gombra kattintva ellenõrizzük, hogy az átmenet iránya 0 fokos-e, vagyis fentrõl lefelé a háttérszínbõl az elõtérszínbe történik-e az átmenet, majd kattintsunk a szövegre. (Kideríthetetlen, hogy mikor és miért, de az Options gombra kattintva néha "elszáll" a PSP – mind a 4.12, mind a 4.14 –, ezért elõtte mentsük el a képet.)

Az Image -> Deformations -> Skew funkcióval vízszintesen (Horizontal) döntsük meg 45 fokkal a szöveget, a függõleges (Vertical) deformáció legyen nulla fok, majd szüntessük meg a kijelölést (Selections -> Select None vagy [Shift N]) és az Image -> Normal Filters -> Soften More-ral kenjük bele a háttérbe.

Ezután válasszuk megint a szövegeszközt, hagyjunk mindent változatlanul, és a szöveget helyezzük el úgy, hogy pontosan a létrehozott árnyék "lábához" igazítjuk. Ehhez nagyítsunk bele a képbe, ha szükséges. Válasszunk elõtérszínnek valami szép sötétet, például egy sötétpirost: R: 90, G: 0, B: 0, és ezzel fessük át a szöveget. Ne felejtsük el visszaállítani a kifestés stílusát Solid Colorra! (Egyébként az is megoldás, ha elõbb cseréljük meg a színt és csak utána hozzuk létre az újabb szöveget.)

Végül egy világosabb színnel ismét írjuk ki az eredeti szöveget változatlan beállításokkal úgy, hogy a szöveget az elõzõhöz képest egy képponttal lejjebb és 3-4 képponttal balra helyezzük el. A cikkünkben látható példán egy kicsit még cifráztam a dolgon úgy, hogy a legutoljára elhelyezett szöveget kifestettem egy rózsaszínbõl (R: 255, G: 128, B: 128) sötétpirosba (R: 128, G: 0, B: 0) tartó színátmenettel, ráengedtem egy 40%-os, egyenletes (Uniform) zajt (Image -> Special Filters -> Add Noise), az egészet elkentem egy kicsit (Image -> Normal Filters -> Soften), majd a rózsaszínt elõtérszínnek kiválasztva a már jól ismert Image -> Special Effects -> Hot Wax Coatinggal összemostam.

"Vulkanikus" szöveg
Mai harmadik és egyben utolsó feliratunk rendkívül látványos, de elkészítése sem olyan egyszerû, mint az eddigieké.

Állítsuk az elõtérszínt fehérre, a háttérszínt feketére, majd hozzunk létre egy 400*120-as true color képet. Egy vastagabb betûtípussal (félkövér Revue, 72 pont) hozzuk létre a szöveget, és mentsük el a kijelölést (Selections -> Save). Ezután növeljük meg a kijelölés határát (Selections -> Modify -> Feather vagy [Ctrl H]) 20 egységgel, és cseréljük meg az elõtér- és a háttérszínt (ehhez elegendõ az L alakú nyílra kattintani). Nyomjuk meg kétszer-háromszor a [Del] gombot (vagy Edit -> Clear), majd az elsõ menet zárásaként szüntessük meg a kijelölést (Selections -> Select None vagy [Shift N]).
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Mossuk el egy kicsit az éleket (Image -> Normal Filters -> Blur vagy Blur More). Jelöljük ki a feliratot úgy, hogy elõbb kijelöljük a teljes képet (Selections -> Select All vagy [Shift A]), majd a Selections -> Modify -> Transparent Color ([Ctrl T]) ablakban adjuk meg átlátszónak a háttérszínt vagy a feketét és toleranciának 10-et, végül növeljük meg a kijelölést (Feather) 10-zel. A kijelölt részre engedjünk 20%-os, véletlenszerû zajt (Image -> Special Filters -> Add Noise), ezután használjuk elõbb az Image -> Special Filters -> Dilate, majd az Image -> Normal Filters -> Soften, végül az Image -> Special Filters -> Emboss funkciót.

Töltsük vissza az elmentett kijelölést (Selections -> Load), majd egybõl invertáljuk (Selections -> Invert). Színezzük át egy kicsit a kijelölt részeket a Colors -> Colorize funkcióval 20-as, illetve 255-ös értéket megadva. Ismét invertáljuk a kijelölést, és cseréljük meg az elõtér- és a háttérszínt. Nyomjuk meg egyszer a [Del] gombot, és használjuk megint az Add Noise funkciót, ezúttal 50%-os zajsûrûséggel, majd az elõbb is használt Image -> Special Filters -> Dilate funkciót ezúttal az Image -> Normal Filters -> Blur és az Image -> Special Effects -> Hot Wax Coating követi.

Ismét átszínezés jön, de most 10-es színárnyalat-eltolással. Ezt az Image -> Special Effects -> Cutout effektus követi, kikapcsolt Fill interior with color kapcsolóval, fekete árnyékszínnel, 120-as átlátszatlansággal, 10-es elmosással és hat képpontnyi függõleges és vízszintes eltolással. Végül megszüntetjük a kijelölést (Selections -> Select None) és a Colors -> Adjust -> Highlight/Midstone/Shadow ([Shift M]) funkcióval "kifényesítjük" a feliratot, 70/50/10-es beállítással.

Ovális gomb
E kissé bonyolult, de látványos felirat után térjünk át egy jóval egyszerûbb, ám Web-lapjainkon jól használható objektumra, az ovális gombokra.
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Állítsuk a háttérszínt a Web-oldal háttérszínével megegyezõ színûre, elõtérszínnek válasszunk egy szimpatikus gombszínt, majd hozzunk létre egy 200*100-as true color képet. Kattintsunk a kijelölõ eszközre (szaggatott téglalap), a kiválasztás típusának válasszuk ki az ellipszist, Feather értékének pedig 10-et. Ezután jelöljük ki a kép nagy részét, például a 15;15-tõl 185;85-ig, vagy 10;10-tõl 190;90-ig, majd válasszuk ki a festékes kannát, és ellenõrizzük, hogy egyszínû kifestés (Solid Color) legyen kiválasztva. Végül kattintsunk az ellipszisen belülre.

Ha nem fekete árnyékot szeretnénk használni, akkor változtassuk meg a háttérszínt a jelenleginél kicsit (vagy jóval) sötétebbre, majd az Add Drop Shadow funkcióval hozzunk létre egy kis (5;5 képpontnyi eltolással, 128-as homályossággal és 18-as elmosással) vetett árnyékot, végül szüntessük meg a kijelölést.

Ezzel a gomb készen is van, már csak a feliratot vagy a képet kell elhelyeznünk rajta. Ennek az egyik legegyszerûbb módja, hogy a gomb szövegét létrehozzuk a szövegeszközzel, elhelyezzük a gomb közepén, majd hogy jól látható legyen, ahhoz elõbb megnöveljük a kijelölés határait (Feather) 2 képponttal, megcseréljük az elõtér- és a háttérszínt, majd egyszer megnyomva a [Del] gombot "belevéssük" a szöveget gombba, esetleg egy kis (255/18/3,3) árnyékkal még ki is emeljük. Végül megszüntetjük a kijelölést, és 256 színû, átlátszó hátterû GIF-fé alakítjuk.

Yahoo stílusú gombok
Ha valaki kicsit látványosabb gombokra vágyik, annak szívesen ajánlom figyelmébe a szintén egyszerûen elkészíthetõ 3D-s gombokat, amilyenekkel például a Yahoo site-ján is találkozhatunk.
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Szokás szerint hozzunk létre egy olyan 200*200-as true color képet, amelynek háttérszíne megegyezik a Web-oldal színével, majd állítsuk a hátteret fehérre, az elõteret feketére. Másik lehetõség, hogy a hátteret ugyanolyan színûre állítjuk, mint amilyen a gomb színe lesz, de akkor nem egészen olyan gombot csinálunk, mint a Yahoo-é, hanem csak "egyszerû" 3D-set.

Válasszuk ki a kijelölõ eszközt, azon belül a kör alakú (Circle) kijelölést, a Feather értékét pedig állítsuk 3-ra. Jelöljük ki a képet az 5;5 ponttól a 195;195 koordinátájú pontig, majd a festékes kannával töltsük fel 135 fokos, lineáris színátmenettel. Ezután válasszuk ki megint a kijelölõ eszközt, és elõször kattintsunk valahol a körön kívül, majd jelöljük ki a kép közepét a 30;30 ponttól a 170;170 pontig. Az elõtérszínt állítsuk át fehérre, a háttérszínt pedig olyan a színûre, mint amilyen színû gombot szeretnénk.

Ismét a festékes bödönre lesz szükségünk, ám ezúttal nem lineáris, hanem centrális (Sunburst) átmenetre. Mielõtt az Options gombra kattintanánk, mentsük el az eddig elkészült rajzot (lásd fent), majd állítsuk át a függõleges eltolást 75%-ra, a vízszintest 25%-osra, végül kattintsunk a körre. Ezzel a gomb már elkészült, csupán a felirat vagy kép hiányzik róla. Például nagyon szép körvonalas szöveget, képet készíthetünk rá, ha a szöveget (például egy Windings karaktert) feketével ráírunk, megnöveljük a kijelölés határát (Feather) 5 képponttal, majd négyszer-ötször megnyomjuk a [Del] gombot, így elkenjük a szélét, végül ugyanoda, ugyanazokkal a beállításokkal rátesszük ismét a szöveget, ám ezúttal fehérrel vagy a gomb színével.
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Sorozatunkban foglalkoztunk szövegekkel, gombokkal és mindenféle webes objektumokkal. Most csavarfejeket és gömböket készítünk.
Elsõ lépésként hozzunk létre egy 100*100 képpontos, 16,7 millió színû képet. Az elõtérszínnek válasszunk ki egy matt sötétsárgát (R: 255, G: 200, B: 0), háttérszínnek pedig egy lehetõleg sötét, Web-oldalunk színével megegyezõ színt. Ahhoz, hogy képünk háttérszíne valóban megegyezzen a kiválasztott háttérszínnel, nyomjuk meg a [Del] gombot, vagy használjuk az Edit -> Clear funkciót. Ezután válasszuk ki a kijelölõ eszközt (Selection Tool), a kijelölés típusát állítsuk körre (Selection type: Circle), a Feather értékét pedig nullára, és így húzzunk a kép közepén egy 35*35 képpontos kört. A kijelölés egy másik módja lehet, hogy Wingding betûtípussal írunk egy 44 pontos kis "l" betût a lap közepére, majd kiválasztjuk a Flood Fill eszközt és a jobb gombbal belekattintunk az így létrehozott körbe.
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Most megnöveljük a kör sugarát 10 képponttal, a Selections -> Modify -> Feather ([Ctrl H]) ablakban 10-es értéket megadva. Ezután kétszer meghívjuk az Image -> Special Effects -> Cutout funkciót. Elõször ellenõrizzük, hogy ki van-e kapcsolva a Fill interior with color, majd árnyékszínnek (Shadow color) válasszuk ki a fehéret (White), valamint 100-as átlátszatlanságot (Opacity), 10-es elmosást (Blur), és -5,-5 képpontnyi eltolást. A második annyiban tér el ettõl, hogy az árnyékszín fekete (Black) és +5,+5 képpontnyi lesz az eltolás mértéke. Ezzel készen is van a benyomódás.

Most jön a csavarfej. Elõször szüntessük meg a kijelölést (Selections -> Select None vagy [Shift N]), majd a kijelölõ eszköz változatlan beállításai mellett jelöljük ki a középsõ 22*22 képpontnyi területet, és fessük elõtérszínûre a létrehozott kört. Ha jobban tetszik, akkor használjuk megint a szövegeszközt, ezúttal 28 pontos "l" betût írva. Ismét kétszer használjuk az Image -> Special Effects -> Cutout funkciót, elõször fehér árnyékszínnel, -5,-5 eltolással, majd fekete árnyékszínnel és +5,+5 eltolással. Még annyit változtassunk, hogy az elmosást növeljük meg 20-ra. A belsõ körvonalat kicsit kontúrosabbá tesszük az Image -> Special Effects -> Add Drop Shadow segítségével, fekete színt, 200-as átlátszatlanságot, 2-es elmosást és 0,0 eltolást (!) használva.

Ezután megint megszüntetjük a kijelölést (Selections -> Select None vagy [Shift N]), majd kiválasztjuk a kijelölõ eszközt, átállítjuk téglalap (Rectangle) alakú kijelölésre, és a leendõ csavarunk közepén húzunk egy 22*5 képpontos négyszöget.

Ezt a mûveletet kicsit leegyszerûsíthetjük, ha négy-ötszörös nagyítással dolgozunk. Ezután már nincs más dolgunk, mint az Image -> Special Effects -> Cutout funkcióval elkészíteni a csavar hornyát, fekete árnyékszínt, 150-es átlátszatlanságot, 3-as elmosást és +3,+3 eltolást használva, majd megszüntetni a kijelölést.

3D-s gömbök
És akkor most jöjjön valami egészen más! Felsorolásoknál gyakran használunk pontozott listákat. Ugyanerre a célra használhatnánk az <ul></ul> és az <li></li> HTML tageket is, de ezek valahogy nem az igaziak. Azt is megtehetjük, hogy rajzolunk egy 25*25-ös kört, elmentjük GIF formátumban, és azt használjuk a listaelemek elõtti jelként (bullet). Most azonban próbáljunk két, kicsit bonyolultabb, ám sokkal látványosabb megoldást.

Állítsuk a háttérszínt a Web-oldalunk hátterével azonos színûre, és hozzunk létre egy 200*200-as true color képet, amelynél a háttérszín a háttérszín. (Ez furcsán hangzik, de ha egyszer így van odaírva az ablakba, akkor mit csináljunk?!) Most állítsuk az elõtérszínt feketére, a háttérszínt középszürkére (R: 128, G: 128, B: 128), válasszuk ki a kijelölõ eszközt, ellipszis típusú kijelölést (Selection type: Ellipse) 0-s Feather értékkel, és húzzunk egy 150*90-es ellipszist. Most jön a Flood Fill eszköz, amelyet függõlegesen 50%-os, vízszintesen pedig 0%-os eltolású (Options) centrális színátfolyással (Fill style: Sunburst Gradient) fogunk használni. Kattintsunk egyszer az ellipszis belsejébe, majd forgassuk el (Image -> Rotate vagy [Ctrl R]) balra (Direction: Left) 15 fokkal (Free: 15).
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Az elforgatás hatására két ellipszisünk lesz, egy eredeti és egy elforgatott. Mivel az eredetire nincs szükségünk, megszabadulunk tõle. Ehhez másoljuk a vágólapra az elforgatott ellipszist (Edit -> Copy vagy [Ctrl C]), válasszuk ki az eszközök közül a szemcseppentõt, és kattintsunk a jobb gombbal valahova, ahol a háttérszínünk látszik, majd töröljük az egészet (Edit -> Clear vagy [Del]), végül helyezzük el az elforgatott ellipszist (Edit -> Paste -> As New Selection vagy [Ctrl E]) a kép jobb alsó sarkába. Szüntessük meg a kijelölést (Selections -> Select None vagy [Shift N]), és kétszer-háromszor használva az Image -> Normal Filters -> Blur More funkciót mossuk el az árnyék szélét.

Most jön maga a gömb. Hozzunk létre egy 200*200-as true color képet, amelynek háttere megegyezik az elõzõ kép háttérszínével. Válasszuk ki a kijelölõ eszközt, és húzzunk egy 160*160-as kört (Selection type: Circle). Az elõtérszínt állítsuk át fehérre, a háttérszínt pedig olyan színûre, amilyen gömböt szeretnénk. Használjuk ismét a Flood Fill eszközt radiális színátfolyással, ám ezúttal mind vízszintesen, mind függõlegesen 20%-os középpont-eltolással.

Az igazi 3D-s hatás eléréséhez használjuk kétszer az Image -> Special Effects -> Cutout funkciót. Elsõ alkalommal árnyékszínnek állítsunk be háttérszínt (Background color), átlátszatlanságnak 150-et, elmosásnak 36-ot, vízszintes és függõleges eltolásnak pedig egyaránt -20, -20 képpontot. Második alkalommal az árnyékszín legyen fekete (Black), az átlátszatlanság 150, az eltolás pedig -10,-10. (A Fill interior with color mindkét esetben legyen kikapcsolva.)

Most szüntessük meg a kijelölést (Selections -> Select None vagy [Shift N]) és kétszer-háromszor használjuk az Image -> Normal Filters -> Blur More-t az élek elkenésére. Jelöljük ki ismét a kört ugyanazon paramétereket használva, mint az elején, és másoljuk a vágólapra. Most válasszuk ki azt a képet, amelyen az árnyék van, és illesszük az árnyékához a gömböt (Edit -> Paste -> As New Selection vagy [Ctrl E], majd kézi igazítás). Szüntessük meg a kijelölést, és vágjuk le a felesleges részeket – például úgy, hogy kijelöljük a szükséges területet, majd az Image -> Crop ([Shift R]) funkcióval eltávolíttatjuk a maradékot. Az Image -> Resample ([Shift S]) funkció segítségével kicsinyítsük le gömbünket akkorára, amekkorára szükségünk van, és csak ezután alakítsuk át 256 színûvé, hogy GIF formátumba is el tudjuk menteni.

3D-s gömbök másképpen
Van más módszer is arra, hogy szép gömböket készítsünk. Ismét hozzunk létre egy 200*200-as true color, Web-oldalunk hátterével azonos színû képet. Elõtérszínnek válasszunk egy tetszõleges, lehetõleg élénk színt, például a zöldet (R: 0, G: 255, B: 0).

Válasszuk ki a festékszórót (Airbrush), és állítsuk be úgy, hogy 200 képpont nagyságú (Size), köralakú (Shape: Round), 128-as – maximális – átlátszatlanságú (Opacity) és minta nélküli (Paper texture: None) legyen.
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Ezzel a "palackkal" a kezünkben kattintsunk egyszer (!) a kép kellõs közepébe (100,100). Ezután méretezzük át a képünket 200*150 képpontosra (Image -> Resample vagy [Shift S]). Ehhez mindenképpen ki kell kapcsolni az alapbeállításban "be" állapotban levõ Maintain aspect ratio kapcsolót.

Mivel az elkent szélû kijelöléshez szükségünk lesz egy kis plusz helyre a kép szélén, adjunk 3–3 képpontnyi keretet a képhez (Image -> Add Borders). Ezután válasszuk ki a kijelölõ eszközt, és állítsuk át 3-as Featherû, kör alakú kijelölésre. Húzzunk egy kört 53,53-tól 153,153-ig, majd az Image -> Crop ([Shift R]) funkcióval távolítsuk el az immár felesleges részeket.

Használjuk ismét a kijelölõeszközt 40,15-tõl 60,35-ig, ám ezúttal 20-as Featherrel. Háttérszínnek válasszunk világos zöldet (R: 200, G: 255, B: 200), illetve az elején kiválasztott szín nagyon világos változatát, majd kétszer-háromszor töröljük és kenjük el a kijelölt területet (Edit -> Clear vagy [Del], majd Image -> Normal Filters -> Blur More). Ha elkészült a becsillanás, jelöljük ki a teljes gömböt (kör alakú kijelölés, 1-es Feather, 1,1-tõl 101,101-ig), és forgassuk el balra 45 fokkal (Image -> Rotate vagy [Ctrl R], Direction: Left, Free: 45), majd mielõtt megszüntetnénk a kijelölést, igényeinknek megfelelõen világosítsuk vagy sötétítsük a Colors -> Adjust -> Brightness/Contrast ([Shift B]) segítségével. Végül szüntessük meg a kijelölést, és méretezzük át az Image -> Resample ([Shift S]) funkció segítségével akkorára, amekkorára szükségünk lesz.

A módszer egyszerûen továbbfejleszthetõ. Például a gömb több, különbözõ színû változatából vagy azonos színû, ám különbözõ mértékben elforgatott gömbökbõl animált GIF-et készíthetünk.
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Sorozatunkat a képek megjelölésével, vízjelezésével folytatjuk. Ez a mûvelet például a képgyûjtemények megjelölésére használható.
Természetesen az a legegyszerûbb, ha a képre ráírjuk a szöveget a megfelelõ eszközzel. Ám sokkal elegánsabban is megoldhatjuk a feladatot, úgy, hogy a kép teljes egészét "élvezhetõ formában" hagyjuk, ám mégis jól láthatóan megjelöljük. Ráadásul a bemutatásra kerülõ trükkök egy részével nem csak feliratokat, hanem emblémákat, logókat is "beleüthetünk" a képeinkbe.

A legegyszerûbb megoldás
Legegyszerûbben a szövegeszközt használhatjuk a feliratok létrehozásához, ám ha az Add Text ablakban a mintakeret mellett található Floatingot kikapcsoljuk, akkor nem változtathatjuk meg a szöveg helyét – vagyis esetleg csak több kísérletbõl tudjuk a helyére illeszteni feliratunkat, viszont az így létrehozott szöveg átlátszó lesz. Ennek az az értelme, hogy bár a felirat nem látszik, a körvonalát kijelöltük – és nekünk most éppen erre van szükségünk.




 HYPERLINK "http://www.freeweb.hu/kesro/psp/pict/psp0601.jpg" Sok esetben talán egyszerûbb lehetõség a kijelölésre, ha bekapcsolva hagyjuk a Floatingot, a szokásos módon létrehozzuk a feliratot a kívánt helyen, elmentjük a kijelölést a Selections -> Save utasítással, majd bezárjuk a képet (File -> Close vagy [Ctrl F4]). Ezután újra megnyitjuk (a legegyszerûbb ilyenkor az [Alt F 1] – figyelem, nem [Alt F1]! – billentyûkombináció), és a Selections -> Loaddal betöltjük az elõbb elmentett kijelölést. A második megoldást elsõsorban akkor érdemes használni, ha a feliratot nagyon ki kell centizni, pontosabban pixelezni.

Ha ez megvan, akkor jöhet a "játék". Az így kijelölt területet megváltoztatjuk valamiképp, például a Colors -> Adjust -> Brightness/Contrasttal világosítjuk vagy sötétítjük, Colors -> Colorize-zal átszínezzük, az Image -> Special Filters -> Add Noise-zal szemcsésítjük, és így tovább. Nagyon érdekes megoldás, ha kiválasztjuk az Image -> Special Effects -> Cutout vagy az Image -> Special Effects -> Add Drop Shadow funkciót, majd tetszõleges árnyékszínt, 255-ös átlátszatlanságot (Opacity), 36-os elmosást (Blur) és kisebb, 0–5 képpontnyi vízszintes és/vagy függõleges elmozdulást adunk meg.

Maszkot húzva
A fenti módszer nagyon jól használható egészen addig, amíg csak szöveget akarunk elhelyezni a képen. De hogyan lehet például egy cégemblémát vagy tetszõleges logót használni? A válasz nagyon egyszerû: maszkolással.

Töltsük be a képet, majd hozzunk létre egy vele megegyezõ méretû rajzot. Ezt több módon is megtehetjük. A "hivatalos" út: megnézzük, mekkora a képünk (például View -> Image Information vagy [Shift I]), majd a File -> New utasítást kiadva a megjelenõ New Image ablakban a Width és Height mezõbe beírjuk a megfelelõ értékeket.




 HYPERLINK "http://www.freeweb.hu/kesro/psp/pict/psp0602.jpg" Másik lehetõség, hogy az Edit -> Copy-val ([Ctrl C]) készítünk egy másolatot a vágólapra, majd az Edit -> Paste -> As New Image-dzsel ([Ctrl V]) elhelyezzük a munkaterületen.

A harmadik – és általam javasolt – megoldás, hogy a Window -> Duplicate ([Shift D]) funkcióval készíttetjük el a Paint Shop Próval a másolatot. Ezután állítsuk fehérre az elõtérszínt és feketére a háttérszínt, majd az Edit -> Clear ([Del]) funkcióval hozzunk létre egy üres, fekete képet. Erre a képre kell elhelyeznünk a kívánt feliratot, feliratokat, logókat, egyéb ábrákat. Ez utóbbiakat úgy tudjuk felrakni a lapra, hogy elhelyezzük õket a vágólapon, majd az Edit -> Paste -> As New Selection ([Ctrl E]) funkcióval beillesztjük a képbe. A színes emblémákat elõtte érdemes átalakítani szürkeárnyalatossá, és ha nagyon világosak, akkor negatívba váltani (Colors -> Negative Image).

Ha minden szöveg és képrészlet a helyén van, akkor váltsunk vissza az eredeti képre, majd a Masks -> New -> From Image utasítással rendeljük hozzá a képhez azt, amit az elõbb hoztunk létre. A Source window-nak adjuk meg az új kép nevét. A Create mask from keretben csak akkor kapcsoljuk be a Source luminance-t és az Invert mask datat, ha a létrehozott kép nem fekete alapon fehér, hanem fehéren fekete.

Ezt elvégezve ismét használhatjuk a már ismertetett lehetõségeket: Brightness/Contrast, Colorize stb. Természetesen a Cutout és az Add Drop Shadow effektus ilyenkor nem mûködik, hiszen nincs kijelölés. Fontos még megemlíteni, hogy a maszk hozzárendelése nem dinamikus a programban, vagyis ha menet közben módosítjuk a maszk képét, akkor újra a Masks -> New -> From Image funkciót kell használnunk. Ez a megoldás akkor is nagyon hasznos, ha több képet kell ugyanúgy megjelölnünk. Ám ha a képeink különbözõ méretûek, akkor ez sem tökéletes megoldás, mivel a PSP a kívánt méretûre torzítja a maszkot, és ez többnyire nem felel meg a kívánalmaknak.

Domborodó feliratok



 HYPERLINK "http://www.freeweb.hu/kesro/psp/pict/psp0603.jpg" Használjuk fel eddig szerzett tapasztalatainkat egy nagyon érdekes effektushoz! Töltsünk be egy képet, és hozzunk létre egy vele azonos nagyságú másikat (lásd fent). Erre a képre írjuk fel a szöveget, lehetõleg valamilyen vastagabb betûtípussal, majd szüntessük meg a szöveg kijelölését. Használjuk az Image -> Special Filters -> Emboss függvényt, és errõl a nagyon szürke képrõl készítsünk egy másolatot (Window -> Duplicate vagy [Shift D]). Állítsuk az elõtérszínt fehérre és a háttérszínt feketére, vagy fordítva. Vegyük elõ a festékes kannát (a Flood Fill beállításai: 0-s Tolerance, Solid Color mód), és az egyik képen fessünk minden szürkét fehérre, a másikon pedig feketére. A képek kicsit pöttyösek lesznek, de ez nem baj.

Ezután válasszuk ki az eredeti képet, amelyen a feliratot akarjuk elhelyezni. Húzzunk maszkot a képünkre a Masks -> New -> From Image funkcióval, forrásként választva azt a képet, amelyet feketére festettünk, és az Invert mask databól távolítsuk el az esetleges pipát. Világosítsuk ki a kép maszkon átlátszó részeit a Colors -> Adjust -> Brightness/Contrast funkcióval, világosságnak 50, kontrasztnak 0 százalékot megadva. Távolítsuk el a maszkot (Masks -> Delete), és húzzuk rá a másik, fehér képet, ám ezúttal pipáljuk ki az Invert mask datat. Ezúttal nem világosítjuk, hanem sötétítjük a maszkon átlátszó részt (Brightness: -50%), majd eltávolítjuk a maszkot – és már készen is vagyunk. Ha nem domború, hanem homorú feliratot szeretnénk, akkor cseréljük meg a világosítás-sötétítés menetét – vagyis a fekete maszkot használjuk sötétítésre és a fehéret világosításra.

Elmosódó szélek
Sok esetben jó, ha képeink szélei nem annyira kontúrosak, hanem mintegy beleolvadnak a háttérbe. Ilyenkor használhatjuk a következõ megoldást.




 HYPERLINK "http://www.freeweb.hu/kesro/psp/pict/psp0604.jpg" A már szokásos módon betöltjük a képet, és létrehozunk egy vele azonos méretû, fehér hátterû rajzot, melyre egy 10 képpont széles fekete keretet húzunk. Ezt megtehetjük például a Shapes eszközzel (legutolsó a listában), de némi finesszel is. Az Image -> Resample segítségével lekicsinyítjük a rajzot mind vízszintesen, mind függõlegesen 20 képponttal, majd a háttérszínt átállítjuk feketére, és az Image -> Add Borderrel létrehozatunk egy 10 képpontos, szimmetrikus keretet. Ezután 5–10 alkalommal használjuk az Image -> Normal Filters -> Blur More funkciót, hogy teljesen elkenjük a keret szélét.

Kiválasztjuk az eredeti képet, ráhúzzuk a maszkot (Masks -> New -> From Image) – figyelni kell arra, hogy az Invert mask data be legyen kapcsolva –, majd a Brightness/Contrast funkcióval, 100%-ot megadva fehérbe, míg -100%-ot megadva feketébe mossuk a kép szélét.

Ennek a megoldásnak az az egyedüli hátránya, hogy csak fehérbe vagy feketébe tudjuk elkenni a széleket. Egy másik megoldással ugyan valamivel kevésbé szépen, ám tetszõleges színû háttérbe is belemoshatjuk képeinket.




 HYPERLINK "http://www.freeweb.hu/kesro/psp/pict/psp0605.jpg" Töltsük be a képet, és állítsuk be a háttérszínt olyan színûre, mint amilyen a Web-oldalunk háttere. Az Image -> Add Borders funkcióval készítsünk a képnek 3 képpont széles keretet. A varázspálcával (Magic Wand) kattintsunk a keretre, majd a Selections -> Inverttel ([Shift V]) jelöljük ki a képet. Most már nincs más dolgunk, mint négyszer használni az Image -> Special Effects -> Cutout utasítást, árnyékszínnek (Shadow color) a hátteret (Background Color), átlátszatlanságnak 255-öt, elmosásnak 18-at, eltolásnak pedig rendre 0,+3; 0,-3; +3,0; és -3,0 értékeket megadva.

Ezt a megoldást még látványosabbá tehetjük azzal, hogy a keret hozzáadása után a kijelölõ eszközt használva kiválasztunk egy kör vagy ellipszis alakú területet (Selection type, Ellipse vagy Circle). Ezután invertáljuk a kijelölést a Selections -> Inverttel (Shift V), az Edit -> Clearrel ([Del]) töröljük a feleslegessé vált részeket, majd ismét invertálunk, hogy újra csak a kiválasztott részlet legyen kijelölve. És csak ezek után kenjük el a széleket az elõbb bemutatott módon. Ha nem akarunk a képbõl további részeket elveszíteni, akkor a Cutout helyett használhatjuk az Add Drop Shadow effektust +3,+3; +3,-3; +3,-3; és -3,-3 eltolási értékeket megadva.

Egy érdekes keret



 HYPERLINK "http://www.freeweb.hu/kesro/psp/pict/psp0606.jpg" Az e havi penzumot egy érdekes, ám nagyon egyszerûen létrehozható kerettel fejezzük be. Ehhez töltsünk be egy képet, a háttérszínt állítsuk át a Web-oldalunkkal megegyezõ színûre, az elõtérszínt pedig valami ettõl jelentõsen elütõ, élénk színûre. Az Image -> Add Borderrel készítsünk a képhez körben 50 képpont széles keretet.

Válasszuk ki a varázspálcát (Magic Wand), és állítsuk a toleranciát 1-re, a Feathert pedig 0-ra. Kattintsunk a keretre, invertáljuk a kijelölést, majd háromszor-négyszer használjuk az Image -> Special Effects -> Add Drop Shadow effektust elõtérszínû (Foreground Color) árnyékszínnel (Shadow Color), 255-ös átlátszatlansággal, 36-os elmosással, valamint 0,0 eltolási értékekkel. Ezt a mûveletsort – varázspálca, invertálás, vetett árnyék – ismételjük meg néhány alkalommal, majd a legvégén az Add Drop Shadow helyett az Image -> Crop ([Shift R]) segítségével vágjuk le a felesleges részt.
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Sorozatunk legutóbbi részében képünk köré egy egyszerû keretet "rajzoltunk". Most annál kicsit bonyolultabban elkészíthetõ, ám annál látványosabb keretek készítésével folytatjuk.
[image: image49.jpg]


Mint mindig, most is az egyszerûbbtõl haladunk a bonyolultabb megoldás felé, bár mint látni fogjuk, néha az egyszerûbb is elég munkát ad. 

Egyszerû fakeret
 Elõször is töltsük be a képet, amit be szeretnénk keretezni, a háttérszínt pedig állítsuk be a Web-oldalunk háttérszínével megegyezõ színûre. Ezután jelöljük ki a bekeretezendõ részt, ami lehet a teljes kép, ez esetben a legegyszerûbb a Selections -> Select All ([Shift A]) funkcióval kijelölni, vagy például a kiválasztó eszközt átállítani ellipszis vagy kör kijelölésre és így kijelölni a kívánt részt. Az Edit -> Copy funkcióval ([Ctrl C]) kimásoljuk a vágólapra, majd létrehozunk egy új képet az Edit -> Paste -> As New Image ([Ctrl V]) segítségével. Ismét kijelöljük a képet – vagy újra a kijelölõ eszközt használva vagy a varázspálcával (Magic Wand). 
Ezt a lépést elhagyhatjuk, ha elõzõleg a teljes képet vagy egy téglalap alakú területet jelöltünk ki. Háttérszínnek állítsunk be feketét, elõtérszínnek barnát (R: 128, G: 64, B: 0). Töröljük a kijelölt területet (Edit -> Clear vagy [Del] gomb), válasszuk ki a festékszórót (Airbrush) és állítsuk be a következõ módon: a méret (Size) 200, a forma (Shape) kör (Round), az átlátszatlanság (Opacity) 128, a textúra (Paper texture) pedig faszerû (Woodgrain). Ezekkel a beállításokkal fessük ki a kijelölt részt. Fõleg a szélekre ügyeljünk, a közepe úgysem fog látszani. Az Image -> Resample ([Shift S]) segítségével növeljük meg úgy a képméretet, hogy mind vízszintesen, mind függõlegesen kétszer annyit adunk a jelenlegi méretekhez, mint amilyen széles keretet szeretnénk. Erre a képre középre elhelyezzük az eredeti, jelenleg a vágólapon levõ képet – Edit -> Paste -> As New Selection ([Ctrl E]) –, majd úgy helyezzük el a kijelölést, hogy a bal felsõ sarok koordinátái megegyezzenek a keretszélességgel.




 HYPERLINK "http://www.freeweb.hu/kesro/psp/pict/psp0702.jpg" Kétszer-kétszer használjuk az Image -> Special Effects -> Add Drop Shadow és az Image -> Special Effects -> Cutout effektust fekete árnyékszínnel, 255-ös átlátszatlansággal, 36-os elmosással, és egyszer +1,+1, egyszer pedig -1,-1 eltolással. A háttérszínt állítsuk át ismét a Web-lap háttérszínére, és így adjunk körben 5 képpont széles keretet a képhez. A varázspálcával kattintsunk a keretre, majd ismét kétszer-kétszer alkalmazva az Add Drop Shadow és a Cutout effektust "belenyomjuk" az egészet a háttérbe.

Más elõtérszínt és más mintát választva a fenti módszerrel további érdekes kereteket hozhatunk létre.

Klasszikus képkeret
A Weben kalandozva találkoztam egy látványos, ám könnyen elkészíthetõ keret "receptjével". Az eredeti leírásban kétszer is szerepel egy speciális effektus, a Filters Factory Gallery A-ban található Pool Shadow, ám enélkül is közel ugyanarra az eredményre juthatunk, így ezt a lépést egyszerûen átugorhatjuk. Ha valaki mégis ragaszkodik a teljességhez, akkor ezt a bedolgozó modult (plug-int) megtalálja az Interneten több helyen is, illetve a CHIPtár Corel számának CD-mellékletén.

A kezdéshez – szokásos módon – töltsük be a bekeretezendõ képet, majd állítsuk át a hátteret matt arany (R: 190, G: 170, B:115), az elõteret pedig sötétarany (R: 90, G: 80, B: 45) színûre. Ha ezzel megvagyunk, akkor az Image -> Add Borderrel hozzunk létre a kép körül egy 5-10 képpont széles keretet. (Az itt megadott érték hatszorosa lesz a végsõ keretvastagság.)




 HYPERLINK "http://www.freeweb.hu/kesro/psp/pict/psp0703.jpg" A varázspálcával (Magic Wand) kattintsunk a keretre, de még elõtte állítsuk át a Feather értéket 1-re. Ezután az alapbeállítások megváltoztatása nélkül használjuk az Image -> Plug-in Filters -> Filters Factory Gallery A -> Pool Shadow effektust. (Ehhez elõtte a File -> Preferences -> General Program Preferences utasításra megjelenõ ablak Plug-in Filters lapján egyrészt engedélyezni kell a külsõ bedolgozók használatát, másrészt meg kell adnunk a gyûjtemény alkönyvtárának elérési útját.) Az Image -> Special Effects -> Buttonize effektust alkalmazzuk 2%-os élszélességgel (Edge Size) és átlátszó szélekkel (Transparent Edge), majd szüntessük meg a kijelölést (Selections -> Select None vagy [Shift N]).

Újra adjunk körben keretet a képekhez (Image -> Add Borders), ám ezúttal az elõzõ érték négyszeresét (20-40 képpont) adjuk meg keretszélességként, és ezt a keretet is jelöljük ki a varázspálcával. A festékszórót (Airbrush) állítsuk be úgy, hogy 200 képpontnyi (Size), kör alakú (Shape: Round), 100-as átlátszatlanságú (Opacity) és pergamen mintázatú (Paper texture: Parchment) legyen, és így menjünk végig a kereten egyszer. Kenjük el az egészet egy kicsit az Image -> Normal Filters -> Blur vagy Blur More segítségével, majd fehérre állítva az elõtérszínt hozzuk létre a tényleges mintát az Image -> Special Effects -> Hot Wax Coating segítségével. Egy kicsit világosítsuk ki a Colors -> Adjust -> Brightness/Contrast funkcióval, 10-15-ös világosság és 0 kontraszt értéket megadva. Invertáljuk a kijelölést (Selections -> Invert vagy [Shift V]), majd a keretezéseknél megszokott módon kívül-belül kenjük el az éleket az Image -> Special Effects -> Add Drop Shadow és a Cutout effektussal, ezúttal is fekete árnyékszínt, 255-ös átlátszatlanságot és 36-os elmosást használva, valamint egyszer +2,+2, egyszer pedig -2,-2 eltolási értékekkel. Ha mind a négy lépéssel megvagyunk, akkor szüntessük meg a kijelölést (Selections -> Select None vagy [Shift N]).

Végül ismételjük meg a belsõ keretnél leírt lépéseket. Az Image -> Add Borderrel hozzunk létre a kép körül egy ugyanolyan széles keretet, mint a legelején. A varázspálcával jelöljük ki a keretet, és engedjük rá az Image -> Plug-in Filters -> Filters Factory Gallery A -> Pool Shadow effektust, majd az Image -> Special Effects -> Buttonize effektust alkalmazzuk 2%-os élszélességgel (Edge Size) és átlátszó szélekkel (Transparent Edge). Legvégül pedig kétszer használva az Add Drop Shadow-t – egyszer +2,+2, egyszer -2,-2 eltolással – mossuk el egy kicsit a széleket.

Ez a keret – véleményem szerint – egyébként elsõsorban nem a Webre való (bár ott sem néz ki rosszul), hanem a számítógépes képek – rajzok, digitális fényképezõgéppel készült vagy scannelt képek stb. – még látványosabbá tételére, például nyomtatáshoz.

Montázsok
Ha már a képeknél tartunk, nézzük meg, hogyan készíthetünk egyszerûen montázsokat a Paint Shop Pro segítségével.

Töltsük be a montázs elkészítéséhez szükséges képeket, majd válasszuk ki azt a képet, amely az egész montázsnak az alapja lesz. Ehhez a képhez igazodva végezzük el a szükséges retusálásokat, méretezzük át a többi képet, tüntessük el a feleslegesnek ítélt részleteket stb.




 HYPERLINK "http://www.freeweb.hu/kesro/psp/pict/psp0704.jpg" Ezután válasszuk ki az elsõ másolandó képet és a kiválasztó eszközzel (Selection Tool) jelöljük ki a kívánt részletet. Elõtte természetesen a kiválasztás típusát állítsuk (Selection type) át a megfelelõre, például kör alakú részlet esetén Circle típusúra. Ízlés szerint vagy már ilyenkor beállítunk egy 5 és 20 közötti Feather értéket, vagy – és én inkább ezt javaslom – a sikeres kijelölés után növeljük meg a kijelölt terület nagyságát a Selections -> Modify -> Feather ([Ctrl H]) funkcióval.

Másoljuk az egészet a vágólapra (Edit -> Copy vagy [Ctrl C]), jelöljük ki az alapnak kiválasztott képet és helyezzük rá a képrészletet az Edit -> Paste -> As New Selection ([Ctrl E]) vagy As Transparent Selection ([Ctrl Shift E]) funkciók valamelyikével. Nem kell megijedni attól, hogy csúnya keret veszi körbe a képrészletet miközben a helyére mozgatjuk – amint megnyomjuk az egér gombját, azonnal el fog tûnni, és a részletünk "belemosódik" a háttérbe.




 HYPERLINK "http://www.freeweb.hu/kesro/psp/pict/psp0705.jpg" Sajnos sok (a legtöbb?) képrészlet nem négyzet, téglalap, kör vagy ovális alakú, így a fenti megoldást nem mindig tudjuk használni. Ám ez nem jelenti azt, hogy ne tudnánk a problémát megoldani a PSP-vel. Szabálytalan alakú kivágásokat kétféleképpen is készíthetünk.

A biztos kezûek használhatják a szabadkézi kijelölõt (Freehand Tool), míg a többiek használhatják azt a megoldást, hogy beállítanak egy tetszõleges színt elõ- és háttérszínnek, majd apránként erre a színûre festik az összes felesleges részt. Ehhez sokat kell "játszani" a Flood Fill eszköz Tolerance értékével, hogy lehetõleg egyszerre minél nagyobb, ám csak a szükséges területet fesse, illetve használhatjuk a varázspálcát (Magic Wand) és az Edit -> Clear ([Del]) funkciót. Vagyis kattintunk valahol a háttéren, majd megbizonyosodva arról, hogy valóban jó a kijelölés, megnyomjuk a [Del] gombot.

A két módszert vegyíthetjük is, sõt sokszor egyszerûen az ecsettel is eltüntethetjük a nem kívánt pöttyöket. Ha a képen már csak a kívánt képrészlet látható, akkor a varázspálcával rákattintunk a háttérre, és a Selections -> Invert ([Shift V]) funkcióval kijelöljük a kívánt képrészletet. Ezután már a "szokásos úton" mehetünk tovább: Selections -> Modify -> Feather, Edit -> Copy, képváltás, Edit -> Paste -> As New/Transparent Selection, elhelyezés.

Ilyen montázsokkal nagyon látványos menüket is készíthetünk Web-lapjainkra, de akkor szükségünk lesz egy olyan programra, amellyel egyszerûen megcsinálhatjuk a képekhez tartozó térképet.
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Múlt hónapban két dekoratív keretet készítettünk. A mostani részt is képkeretezéssel kezdjük, mégpedig kicsit egyszerûbb és gyorsan elkészíthetõ keretekkel.
Természetesen ezúttal is azzal indulunk, hogy betöltjük a bekeretezendõ képet. Ezután létrehozunk egy másik, ezzel azonos méretû, fekete-fehér vagy szürkeárnyalatos képet. Ezt elkészíthetjük úgy is, hogy a View -> Image Information funkcióval ([Shift I]) megnézzük, hogy mekkora a kép, majd kiadjuk a File -> New utasítást, és a megjelenõ New Image ablakban a Width és a Height mezõbe beírjuk a megfelelõ értékeket.

Sokkal egyszerûbb az a megoldás, amit a hatodik részben is mutattam: a Window -> Duplicate ([Shift D]) funkcióval létrehozunk egy másolatot, az Edit -> Clearrel kitöröljük a tartalmát, majd a Colors -> Gray Scale-lel vagy a Colors -> Decrease Color Depth -> 2 Colors-szal átalakítjuk a kívánt formátumúvá. Erre a másolatra rajzoljuk meg a keretet úgy, hogy a kép széle fekete, míg a közepe – ahol a képünk látszani fog – fehér legyen.




 HYPERLINK "http://www.freeweb.hu/kesro/psp/pict/psp0801.jpg" Ilyen kereteket egyébként több grafikus programmal is kapunk "bónuszként", és az Interneten is található jó néhány. CD-mellékletünkön – a szokásos bemutatóoldal alján – is található tíz fekete-fehér és öt szürkeárnyalatos, elõre elkészített keret. Ha "félkész" kereteket – akár mások által rajzoltat, akár a mi régebbi keretünket – használjuk, akkor azokat át kell méretezni akkorára, amekkora az eredeti kép. A fekete-fehér kereteknél használjuk az Image -> Resize, míg a szürkeárnyalatosoknál az Image -> Resample funkciót.

Ha készen van a keret, akkor jelöljük ki az eredeti képet, majd a Masks -> New -> From Image utasítással "takarjuk le". Forrásablakként (Source window) természetesen a keret ablakát adjuk meg. Szürkeárnyalatos keretnél lényeges, hogy a maszk mindenképpen a világosságtól függõ legyen (Create mask from: Source luminance), illetve mivel úgy rajzoltuk a keretet, hogy kívül fekete, belül fehér, ezért az Invert mask data mezõt ki kell pipálnunk.




 HYPERLINK "http://www.freeweb.hu/kesro/psp/pict/psp0802.jpg" Ezután már nincs más dolgunk, mint kifesteni a keretet. Ehhez nem kell mást tennünk, csak egyszerûen kiválasztani a festékes kannát (Flood Fill Tool), a Match mode-ot None-ra állítani – vagy ha valakinek egyszerûbb, a Match mode-ot hagyhatja RGB Value-n, a tûréshatárt (Tolerance) állítsa át 200-ra –, majd egy tetszõleges elõtérszínt beállítva kattintani a kép bármely pontján.

Akkor sincs probléma, ha mintás keretre vágyunk, erre is rengeteg egyszerû megoldás létezik. Például az ecsetet elõvéve (Paint Brushes Tool) kiválasztunk valamilyen mintát (Paper texture) és egy hozzá tartozó színt, majd körberajzoljuk a keretet. Nem kell attól félnünk, hogy kárt teszünk a képben, hiszen pont ezért húztuk rá a maszkot.

Ha olyan mintára vágyunk, amely nem található meg a Paint Shop Pro eredeti készletében, akkor sincs gond. Rajzoljuk meg a mintát, vagy ha már készen van, akkor töltsük be, válasszuk ki a festékes bödönt, majd a kifestési mód (Fill style) listából válasszuk ki a mintásat (Pattern). Kattintsunk az Options gombra, és a New pattern source listában keressük meg a mintát tartalmazó ablak nevét. Ha ezzel megvagyunk, akkor nincs más dolgunk, mint rákattintani az eredeti kép bármely pontjára, és kész a mintás keret.

Fényképbõl festmény, avagy esõcsinálás
A most következõ két "trükkben" több közös vonás is van. Az egyik, hogy gyakorlati hasznuk ugyan igen kevés – legalábbis így, ebben a formájukban nem igazán tudom, hogy mire használhatók –, de technikai szempontból mindkettõ tartalmaz néhány érdekességet.




 HYPERLINK "http://www.freeweb.hu/kesro/psp/pict/psp0803.jpg" Nézzük elõször, hogyan tudunk a Paint Shop Próval fényképbõl "festményimitációt" készíteni. (Ilyen effektus egyébként szinte mindegyik "nagy" rajzolóprogramban – Photoshop, Photo-Paint stb. – található.)

Töltsük be a fényképet, és azon nyomban készítsünk róla egy másolatot (Window -> Duplicate vagy [Shift D]). Hagyjuk a duplikátumot kijelölve, és forgassuk (Image -> Rotate vagy [Ctrl R]) el jobbra (Right) 25 fokkal (Free: 25). Az Image -> Special Filters -> Add Noise funkcióval szórjuk tele apró pöttyökkel a képet (Random, 40%), majd az egészet kenjük el az Image -> Deformations -> Wind segítségével (From left, 2). Most fordítsuk vissza a képünket (Image -> Rotate, Left, 25 fok), a Selections Toollal jelöljük ki az eredeti képet (az elforgatástól létrejött egy háttérszínû keret körülötte), és az Image -> Croppal ([Shift R]) vágjuk le a felesleget. Az elmosódás miatt kicsit nehéz megtalálni az eredeti kép széleit, ehhez lehet, hogy több próbára is szükség lesz, ám a képet ugyanakkorára kell vágnunk, mint amekkora eredetileg volt.




 HYPERLINK "http://www.freeweb.hu/kesro/psp/pict/psp0804.jpg" Ha ezzel megvagyunk, akkor váltsunk át az eredeti képre, jelöljük ki az egészet (Selections -> Select All vagy [Shift A]), majd a Selections -> Modify -> Overall Opacity ([Ctrl Y]) funkcióval "halványítsuk el" a kijelölést 40%-kal. Ezt a halványítást most még nem látjuk, de mindjárt kiderül, hogy mit jelent. Az Edit -> Copy ([Ctrl C]) paranccsal másoljuk az egészet a vágólapra, majd váltsunk vissza a módosított képre és helyezzük rá a félig áttetszõ képünket az Edit -> Paste -> As New Selectionnel ([Ctrl E]), a 0,0 koordinátánál (lásd a státuszsor bal szélét). Amikor mozgatjuk a képet, akkor az teljesen átlátszatlan, de amikor letesszük, akkor egybõl kiderül, hogy miért volt szükség az Overall Opacity-s lépésre. Szüntessük meg a kijelölést (Selections -> Select None vagy [Shift N]), és gyönyörködjünk a mûvünkben. A zaj nagyságát, a "szélerõt", illetve az eredeti kép átlátszóságát változtatva szabályozhatjuk, hogy milyen legyen a "mûvészeti hatás".




 HYPERLINK "http://www.freeweb.hu/kesro/psp/pict/psp0805.jpg" Az "esõcsináláshoz" válasszunk egy tetszõleges tájképet. Lehetõleg ne olyat, amelyiken esik az esõ, mert abban nem lesz semmi kunszt. Ha betöltöttük a képet, akkor hozzunk létre egy legalább kétszer ekkora fekete hátterû, szürkeárnyalatos képet. Ha például 640*480-as a képünk, akkor az új kép mérete legalább 1280*960 képpont legyen. Állítsuk az elõtérszínt fehérre, majd ismét 40%-os véletlenszerû szórással használjuk az Image -> Special Filters -> Add Noise funkciót. A változatosság kedvéért most az Image -> Deformations -> Windet 10-es erõsségûre állítjuk (teljesen mindegy, hogy balról vagy jobbról "fúj"), és így kenjük el a pöttyöket. Forgassuk el a képet 45 fokkal (Image -> Rotate vagy [Ctrl R]), majd vágjunk ki középrõl egy akkora darabot, amekkora a tájképünk (Selection Tool és Image -> Crop vagy [Shift R]).

Váltsunk vissza az eredeti képre, és a Masks -> New -> From Image utasítással húzzuk rá erre az imént létrehozott képet. Lényeges, hogy a mszkunk világosságfüggõ legyen (Source luminance), és az Invert mask data ne legyen bekapcsolva. Ellenõrizzük, hogy az elõtérszín fehér-e, válasszuk ki a festékes kannát (Flood Fill Tool), kapcsoljuk ki a színfigyelést (Match mode: None) vagy a toleranciát állítsuk maximálisra (Tolerance: 200). Kattintsunk a kép tetszõleges pontjára és figyeljük a hatást.




 HYPERLINK "http://www.freeweb.hu/kesro/psp/pict/psp0806.jpg" Az esõ milyenségét többféleképpen is befolyásolhatjuk. Például azzal, hogy a "zajosításnál" mekkora értéket adunk meg, hiszen kisebb (5-10%) értéket megadva ritkább, míg nagyobb (50-100%) érték esetében sokkal sûrûbb lesz az esõfüggöny. Vagy az elforgatás szöge a "szélerõsséget" változtatja, hiszen kisebb értéket megadva viharos erejû lesz a szél ("vízszintesen esnek a cseppek"), míg közel 90 fokos elforgatásnál szélcsendes záport idézhetünk elõ. Végül attól függõen, hogy egyszer vagy többször kattintunk a képre lesz ismét csak sûrûbb vagy ritkább a zivatar.

Ismét felirat
Az elmúlt idõben többne is reklamáltak, hogy régen volt szó a látványosabb feliratokról. Akkor hát, íme.

Hozzunk létre egy fekete hátterû, true color (16,7 millió színû), 400*100 képpont méretû képet, és állítsuk át az elõtérszínt fehérre. Erre a képre helyezzük el a feliratot egy lehetõleg kövérebb és kerekebb betûtípussal (például Balloon ExtraBold). Az élsimítást (Antialias) és a "lebegtetést" (Floating) ne felejtsük el bekapcsolni. Szüntessük meg a kijelölést például oly módon, hogy a jobb gombbal kattintunk valahova a képen, de természetesen használhatjuk a Selections -> Select None ([Shift N]) utasítást is. A betûk széleit mossuk el egy kicsit az Image -> Normal Filters -> Blur vagy Blur More használatával. Nagyobb méretû (100-120 pontnál nagyobb) szövegek esetén akár többször is használhatjuk.

Ezután ismét jelöljük ki a szöveget úgy, hogy elõször kijelöljük a teljes képet (Selections -> Select All vagy [Shift A]), majd a kijelölésbõl kihagyjuk a háttérszínû pontokat a Selections -> Modify -> Transparent Color ([Ctrl T]) segítségével (Transparent Color: Background Color, Tolerance: 0). Növeljük meg egy kicsit – egészen pontosan 10 egységgel – a kijelölés határait a Selections -> Modify -> Feather ([Ctrl H]) révén. Ha idáig eljutottunk, akkor készítsünk egy másolatot a képrõl (Window -> Duplicate vagy [Shift D]). Használjuk az Image -> Special Filters -> Emboss effektust, majd a Colors -> Adjust -> Brightness/Contrast ([Shift B]) segítségével egy kicsit világosítsuk ki (Brightness: 10, Contrast: 0). Ezután a Colors -> Negative Image-dzsel fordítsuk meg a világossági viszonyokat.

Most jön a varázslat. A Colors -> Adjust -> Highlight/Midstone/Shadow ([Shift M]) funkcióval eltávolítjuk a felesleges részeket, és csak a számunkra lényeges, világos területeket tartjuk meg. Azt, hogy mit nevezünk ez esetben világosnak, a Highlight értékével adhatjuk meg. Alaphelyzetben javaslom a Highlight: 80, Midstone:50, Shadow: 80 értékeket, de mint említettem, érdemes megfigyelni, hogy a Highlight értékét megváltoztatva és a Preview gombot megnyomva miként módosul a kép.
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Jelöljük ki feliratot tartalmazó képet, majd használjuk annyiszor az Edit -> Clear ([Del]) parancsot, amíg a felirat el nem tûnik teljesen. Most válasszunk egy tetszõleges elõtérszínt vagy mintát, és egyszer kattintsunk a festékes kannával a bekeretezett részre. Lényeges, hogy csak egyszer, mert ugyan jobban kitölti a keretet a szín vagy a minta, ha többször kattintunk, ám ettõl vastagabb lesz szöveg, és a fények nem jó helyre fognak esni.

Használjuk a már jól ismert Masks -> New -> From Image funkciót a szokásos ódon. Source window: az elõzõleg létrehozott kép, Create mask from – Source luminance, Invert mask data – üresen hagyva. Ezután már nincs más dolgunk, mint a Colors -> Adjust -> Brightness/Contrast ([Shift B]) funkciót különbözõ világosítási (Brightness) értékekkel egyszer vagy többször használva elérjük a végsõ hatást. Azzal is érdekes eredményre juthatunk, ha nem festjük ki feliratot, hanem csak kitöröljük, majd ezután bekapcsolva a maszkot egyszer (vagy többször) ráöntünk valamilyen egyszínû vagy mintás festéket a szövegre. Jó kísérletezést!
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A sorozat eddigi részeiben szinte kizárólag statikus objektumokkal foglalkoztunk, pedig a Web-oldalainkon használhatunk "mozgó alkatrészeket" is.
Ilyenek például az animált GIF-ek, vagy az "egérérzékeny" menük. Most ez utóbbiakkal foglalkozunk.

Ehhez szükség lesz némi JavaScript programozásra – egészen pontosan az OnMouseOver és az OnMouseOut esemény lekezelésére –, ám ettõl nem kell megijedni. 1998 októberi számunk CD-ROM-ján a \CIKKEK\PSP alkönyvtárban található HTML oldalak és az INDEX.JS vagy a MENU.JS file segítségével minden programozói ismeret nélkül bárki elkészítheti saját javascriptes oldalait, menüit. Nem kell mást tenni, mint – szükség esetén – átnevezni a file-okat, a .JS file-okban átírni a képek nevét és a megjegyzés szövegeket, illetve a .HTM file-okban értelemszerûen átírni a hivatkozásokat és a képfile-ok adatait.

Mielõtt elkezdenénk ezt a munkát, gondoljuk végig, hogy milyen menüpontok lesznek az oldalakon, majd készítsük el mindegyikhez a két-két képet. Elõször is létrehozzuk a normál, vagyis inaktív állapotot, majd ebbõl valamilyen effektussal, torzítással elkészítjük a kiemelt, vagyis aktív állapotot.
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Az egyik legegyszerûbb megoldás, ha átfestjük a szöveget, akár egyszínû, akár színátmenetes, akár mintás "pemzlivel". A szöveg újra kijelöléséhez használjuk a sorozatunkban már többször bemutatott trükköt: jelöljük ki a teljes rajzot (Selections -> Select All vagy [Shift A]), majd a kijelölésbõl vegyük ki a hátteret (Selections -> Modify -> Transparent Color vagy [Ctrl T]; Transparent Color: Background Color, Tolerance: 20).
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 INCLUDEPICTURE "file:///C:/WINDOWS/TEMP/msoclip1/05/clip_image079.jpg" \* MERGEFORMATINET [image: image43.jpg]Blur More
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Az átszínezésen kívül rengeteg más lehetõséget is kínál a Paint Shop Pro. Például átméretezhetjük a szöveget (Image -> Resample vagy [Shift S]), ha ehhez van elegendõ hely az oldalon, az olvashatóság határáig elmoshatjuk a széleit 10-15-ször használva az Image -> Normal Filters -> Blur More funkciót, vagy mindkét irányba – mérettõl függõen 5-10-es erõsséggel – "megfújjuk" az Image -> Deformations -> Wind effektussal, az Image -> Special Filters -> Add Noise (akár többszöri) használatával bepöttyöztethetjük, hogy csak néhányat említsek a több tucat lehetõségbõl.
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 INCLUDEPICTURE "file:///C:/WINDOWS/TEMP/msoclip1/05/clip_image081.jpg" \* MERGEFORMATINET [image: image45.jpg]Add Noise
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Csak árnyaltan
A fenti megoldások bármelyikével is megoldhatjuk a problémát, ám természetesen nem kell lemondanunk kedvenc effektusaink (3D, arany, ezüst, fa, tégla stb.), felhasználásáról, legfeljebb más megoldást kell találnunk. Például elkészítjük az aranyozott feliratot egészen odáig, hogy már csak a térbeli hatást kihangsúlyozó árnyékolás van hátra, és errõl az állapotról készítünk egy másolatot. Visszatérünk az "eredeti" képhez, és létrehozzuk az árnyékot mondjuk +5;+5 eltolással, és elmentjük ezt a képet mint normál állapotot.

Ezután a másolatból elkészítjük az "aktív" változatot. Elõször is kijelöljük a teljes képet (Selections -> Select All vagy [Shift A]), kimásoljuk a vágólapra (Edit -> Copy vagy [Ctrl C]), majd új kijelölésként rögtön vissza is tesszük (Edit -> Paste -> As New Selection vagy [Ctrl E]) úgy, hogy a bal felsõ sarok a 2;2 pontra kerüljön (ezt a bal alsó sarokban, a státuszmezõben ellenõrizhetjük). Végül kijelöljük magát a szöveget, és ezúttal +3;+3 eltolással hozzuk létre az árnyékot. Így azt a hatást érjük el, mintha a szöveget benyomnánk, hiszen az árnyék változatlan helyen marad, csak a szöveg kerül hozzá közelebb.
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Ragyogj, ragyogj szövegem!
Az Interneten kóborolva sok érdekes megoldással találkozik az ember. Nekem az tetszett a legjobban, amikor a kiválasztott menüpont körül egy "dicsfény" jelent meg. Ennél az effektusnál is bebizonyosodott, hogy sokszor a legegyszerûbb megoldások egyben a leglátványosabbak.

[image: image47.jpg]=





A normál állapothoz készítsük el a szöveget – akár egyszerûen, akár egy látványos effektussal –, mentsük el, majd készítsünk róla egy másolatot biztos, ami biztos alapon. Jelöljük ki a szöveget (az árnyékával együtt) – [Shift A], [Ctrl T], Transparent Color: Background Color, Tolerance: 20 –, másoljuk a vágólapra (Edit -> Copy vagy [Ctrl C]), és mentsük el a kijelölés jelenlegi állapotát (Selections -> Save).

Ezután szüntessük meg a kijelölést és töröljük a szöveget (Edit -> Clear vagy [Del]), majd készítsük el a háttérfényt. Ehhez válasszunk háttérszínnek élénk, mind a szövegtõl, mind a háttértõl elütõ színt, töltsük vissza a kijelölést (Selections -> Load), növeljük meg a határait (Selections -> Modify -> Feather vagy [Ctrl H]) a mérettõl függõen 10-40 egységgel, majd 5-10 alkalommal nyomjuk meg a [Del] gombot. Ezután helyezzük vissza a szöveget úgy, hogy ismét betöltjük az eredeti kijelölést, és ebbe az Edit -> Paste -> Into Selection ([Ctrl L]) paranccsal illesszük bele a vágólapra kimásolt szöveget mindenestül. Mivel így túlságosan kontúrosak a határok, ezért szüntessük meg a kijelölést (Selections -> Select None vagy [Shift N]), és egy kicsit kenjük el az egészet az Image -> Normal Filters -> Soften funkcióval.

HTML puzzle



 HYPERLINK "http://www.freeweb.hu/kesro/psp/pict/psp0908.jpg" Végül nézzünk meg egy érdekes kirakós játékot! Ehhez válasszunk egy szép, vagy legalábbis látványos 640*480-as vagy nagyobb képet, ami a menünk háttere lesz. Jelöljük ki ennek a képnek a tetejét, ide jön az oldal címe, valamint a bal oldalát, ide jön a menü. (Másképp is elhelyezhetjük az elemeket, ez csak egy megoldás a sok közül.) A kijelölt részekhez adjunk még egy "tépett szélet" a Freehand kijelölõ eszközzel (a lasszó a kijelölõ és a varázspálca között). A többszörös kijelölésekhez mindössze annyit kell tudni, hogy ha a kijelölés alatt nyomva tartjuk a [Shift] billentyût, akkor ezzel a jelenlegi kijelölést hozzáadjuk a meglevõhöz, míg ha a [Ctrl]-t tartjuk nyomva, akkor elveszünk belõle.

Ha meg vagyunk elégedve mûvünkkel, akkor invertáljuk a kijelölést (Selections -> Invert vagy [Shift V]), töröljük a felesleget (Edit -> Clear vagy [Del]), majd újra invertálva a kiválasztást visszatérünk az eredeti állapothoz. A keretet hangsúlyozandó hozzuk létre az árnyékát (Image -> Special Effects -> Add Drop Shadow; Color: Black, Opacity: 255, Blur: 36, Offset: +3,+3), és e rész lezárásaként mentsük el a képet a File -> Save As-szel, nehogy felülírjuk az eredeti képet.

Ezen a háttéren hozzuk létre a menüpontok "gombjait", ráadásul úgy, hogy készítsünk róla egy másolatot, és egybõl kreáljuk meg a normál és az aktív állapotot, ügyelve arra, hogy ugyanoda essenek. Ezután vágjuk szét a képet úgy, hogy a változó képek minél kisebbek (ám páronként azonos méretûek), míg a fix részek minél nagyobbak legyenek (akár függõlegesen, akár vízszintesen). Komoly segítséget nyújthat az a lehetõség, hogy a kijelölést nem csak egérrel, hanem numerikusan is megadhatjuk, ha duplán kattintunk a kijelölõ szerszámra.




 HYPERLINK "http://www.freeweb.hu/kesro/psp/psp9/psp9d.htm" Ezután jön a neheze. Az egészet össze kell rakni egy HTML táblázatban. Itt elõször is arra kell figyelni, hogy a <table> tagben állítsuk nullára a keret és a cellák közötti "rések" nagyságát: <table border=0 cellspacing=0 cellpadding=0>. Utána számoljuk meg azt, hogy összesen hány oszlopból és sorból áll a táblázat, majd azt, hogy mely cellákat kell majd összevonnunk akár vízszintesen, akár függõlegesen, mert ezt a colspan=X és a rowspan=X – ahol X az összevonandó oszlopok, illetve sorok száma – segítségével tehetjük meg.

 

[image: image50.jpg]


[image: image51.jpg]


[image: image52.jpg]


[image: image53.jpg]


[image: image54.jpg]


[image: image55.jpg]


[image: image56.jpg]


[image: image57.jpg]


[image: image58.jpg]


[image: image59.jpg]


[image: image60.jpg]


[image: image61.jpg]


[image: image62.jpg]


[image: image63.jpg]


[image: image64.jpg]L LLLLLL

AlLLLCET




[image: image65.jpg]A



[image: image66.jpg]


[image: image67.jpg]


[image: image68.jpg]


[image: image69.jpg]


[image: image70.jpg]


[image: image71.jpg]


[image: image72.png]


